Command failed with status (127)

byron's Avatar


05 Nov, 2014 02:47 PM

My rake script works locally, but when appVeyor runs it as part of the build, one of the tasks fails:

rake runPepinoSpecs
5348build/Pepino.TestRunner/TestRunner.exe [email blocked] 9876543 Pepino
5349rake aborted!
5350Command failed with status (127): [build/Pepino.TestRunner/TestRunner.exe tes...]
5352Tasks: TOP => runPepinoSpecs

From what I read in the googles, 127 is for "Command not found". I have tried a few different things trying to get it to work in appVeyor, but it still exits with a 127. Like I said, this works great locally. Any clues?

  1. Support Staff 1 Posted by Feodor Fitsner on 05 Nov, 2014 02:53 PM

    Feodor Fitsner's Avatar

    Have you tried specifying absolute path to that exe?


  2. 2 Posted by byron on 05 Nov, 2014 03:18 PM

    byron's Avatar

    I have not, and I don't mind trying it at all. But I have another executable that is also built as part of the rake script and then executed. That executable runs without problem.

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:49 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac