"artifact" setting from yml file being ignored

Nikolaj Carøe's Avatar

Nikolaj Carøe

06 Dec, 2017 09:05 AM

Hi,

The project i am trying to deploy has multiple web projects and the build.publish_wap setting so nicely creates an artifact for each web project

I my appveryor.yml i have the following deploy settings and it seems the deploy.artifact setting is being ignored?

  deploy:
    - provider: Environment
      name: <name of environment>
      artifact: /My.(Shared|ProjectWithArea).Web/
* If i type the regex directly in the Environments settings it works. * If i type a variable in the Environments settings, lets say $(artifact_pattern), and replace artifact: with artifact_pattern: in the above example it works aswell.
  1. Support Staff 1 Posted by Ilya Finkelshte... on 06 Dec, 2017 06:31 PM

    Ilya Finkelshteyn's Avatar

    Nikolaj,

    Syntax you are trying to use (with artifact name in YAML when using Environment deployment) is not supported.I believe that passing $(artifact_pattern) variable is the best way to keep more control in YAML in your case for now.

    I admit that sometime it is difficult to understand what is right YAML syntax. So when in doubt, you can use UI to setup some setting and then press Export YAML to get proper YAML sample. However not all setting are exposed in UI, so feel free to ping us when needed too :)

    Ilya.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac