Latest Appveyor Update causing VC++ projects to fail

jerrywiltse's Avatar

jerrywiltse

30 Jan, 2018 02:13 AM

Numerous C++ projects of ours are not failing unexpectedly during the "sln file upgrade". Rolling back to previous appveyor worker image is successful.

The error from the visual studio solution upgrade log is here (there's one error for each vcxproj).

liblz4\liblz4.vcxproj: The application which this project type is based on was not found. Please try this link for further information: http://go.microsoft.com/fwlink/?LinkID=299083&projecttype=8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942

According to the accepted answer in this post, it means VS is missing some SDK it needs for the project type:
8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942

According to this list, this project type is C++ or Visual C++. Seems pretty standard:
https://www.codeproject.com/Reference/720512/List-of-Visual-Studio-...

This is a simple compression library, don't believe it needs any special SDK's. I think VS is just missing a critical component since the last update.

Please advise.

  1. 1 Posted by jerrywiltse on 31 Jan, 2018 12:24 AM

    jerrywiltse's Avatar

    For the record, here is the project:
    https://ci.appveyor.com/project/BinCrafters/conan-lz4

  2. Support Staff 2 Posted by Ilya Finkelshte... on 01 Feb, 2018 03:54 AM

    Ilya Finkelshteyn's Avatar

    We did not get any other similar reports and I could not repro it with in my fork. Seems that some secure variable is required. Please create repo we could fork and investigate.

    Note that after next update current image will become "previous" so we need to understand what happened before. So public repo and any idea how you could manually fix this with current image will not hurt.

  3. 3 Posted by jerrywiltse on 10 Feb, 2018 04:05 AM

    jerrywiltse's Avatar

    I just tried switching back to the current images, same problem.

    https://ci.appveyor.com/project/BinCrafters/conan-lz4/build/job/lux...

    Here's the repository:
    https://github.com/bincrafters/conan-lz4

    Again, if I just change back to previous, it works :(

    I guess I don't understand what you mean about secure variable being required. Can you provide any more detail about this statement?

  4. Support Staff 4 Posted by Ilya Finkelshte... on 10 Feb, 2018 04:36 AM

    Ilya Finkelshteyn's Avatar

    Let me explain what I mean... I forked your repo, simplified matrix (not needed all that variants for simple repro), set default branch to stable/1.8.0 and started the build. Error I got is 'Exception: Upload not possible, 'password' is missing!'. I did not look deep, but I suspect that this 'password' is taken from some variable entered in UI (as I do not see anything in YAML).

    Generally it would be great to have a repro as much in "hello word" style as possible. We should be able to clone it and have the same error without any knowledge of your build specifics.

    I created this issue to track this, because next image update will make current image to be "Previous" and what you use now as "Previous" will be gone.

    Let me please stress once again that we need as simple and generic repro as possible, this will help us to narrow down the problem. This is especially important in this case where we have other reports of this issue.

  5. 5 Posted by jerrywiltse on 10 Feb, 2018 04:54 AM

    jerrywiltse's Avatar

    I see, yes, I forgot conan checks to make sure you have credentials in place to upload the binaries before trying to compile them. However, it doesnt use them until after successful build. Thus, please just add the following environment variables to your appveyor project and it should satisfy the check, and then proceed to error during build:

    CONAN_LOGIN_USERNAME
    CONAN_PASSWORD

    yes, obviously, would be nice to have generic repro, but all our other builds are working on the current image. can't begin to imagine what's causing, so can't think of good way to isolate.

  6. Support Staff 6 Posted by Ilya Finkelshte... on 10 Feb, 2018 04:59 AM

    Ilya Finkelshteyn's Avatar

    You mean just add those variables with any values?

  7. 7 Posted by jerrywiltse on 10 Feb, 2018 05:01 AM

    jerrywiltse's Avatar

    Yes, any values should do.

  8. 8 Posted by jerrywiltse on 12 Feb, 2018 07:45 PM

    jerrywiltse's Avatar

    Hi Ilya , were you able to reproduce with those variables populated?

  9. Support Staff 9 Posted by Ilya Finkelshte... on 12 Feb, 2018 10:47 PM

    Ilya Finkelshteyn's Avatar

    Just tried that. It says: ERROR: Wrong user or password. [Remote: upload_repo]

    Maybe you need to create some temporary restricted credentials for me. Ping me over email ilyaf at our company dot com, if you decide to do so.

  10. 10 Posted by jerrywiltse on 12 Feb, 2018 11:04 PM

    jerrywiltse's Avatar

    Can you link me to your build log?

    Gerald R. Wiltse
    [email blocked]

  11. Support Staff 11 Posted by Ilya Finkelshte... on 12 Feb, 2018 11:06 PM

    Ilya Finkelshteyn's Avatar
  12. 12 Posted by jerrywiltse on 17 Feb, 2018 09:55 PM

    jerrywiltse's Avatar

    Thanks. Sorry for the back/forth. If you are still willing to spend time on this, please try to build the testing/1.8.0 branch instead. The testing branch does not require credentials, and does not attempt to upload.

  13. Support Staff 13 Posted by Owen McDonnell on 02 Mar, 2018 01:29 AM

    Owen McDonnell's Avatar

    Hi Gerald,
    I did some poking around in the project in question. I can’t say I fully understand your build tools but RDP’d into the build machine and ran devenv (visual studio 12.0) /upgrade manually and got the same error but then tried to use devenv (visual studio 14.0) and the upgrade worked.
    I'm not sure if your build matrix variable 'CONAN_VISUAL_VERSIONS' is set for any other reasons but i was able to successfully build by changing that variable from 12 to 14.

    Would that solution work for you?

  14. 14 Posted by jerrywiltse on 02 Mar, 2018 02:01 PM

    jerrywiltse's Avatar

    Owen,

    Thanks for poking around :)

    Sadly no. Our build tools compile for all 3 VS versions, 12, 14, and 15,
    and upload them to a package manager. Then, the "conan client" downloads
    the appropriate binary based on the MSVC version the user defines. In
    summary, we need to build all three versions.

    Again, it works on the previous image, and doesn't work on the new image.
    Just trying to figure out what parts of the change might have affected
    MSVC12.

    Regards,
    Jerry

    Gerald R. Wiltse
    [email blocked]

  15. Support Staff 15 Posted by Owen McDonnell on 02 Mar, 2018 05:30 PM

    Owen McDonnell's Avatar

    Interestingly, I tried with APPVEYOR_BUILD_WORKER_IMAGE set to 2013 (which is what Visual studio 12 is) and it also worked. Though that doesn't answer why it worked on previous image but not on current, I wonder if it might also address your issue?

  16. 16 Posted by jerrywiltse on 02 Mar, 2018 09:07 PM

    jerrywiltse's Avatar

    We're not going to change the setting, we need to isolate and understand
    the breaking change that was made. I know, it might be really hard, but
    that's what we need right now.

    Gerald R. Wiltse
    [email blocked]

  17. Support Staff 17 Posted by Ilya Finkelshte... on 02 Mar, 2018 09:15 PM

    Ilya Finkelshteyn's Avatar

    Can you please elaborate why devenv /upgrade from Visual Studio 2013 should be called on Visual Studio 2015 image?

  18. 18 Posted by jerrywiltse on 03 Mar, 2018 11:15 PM

    jerrywiltse's Avatar

    I don't know why that is. It was that way on the templates provided by the team that provides our build tools.

  19. 19 Posted by jerrywiltse on 03 Mar, 2018 11:50 PM

    jerrywiltse's Avatar

    I switched the image to the current 2013 image for the MSVC12 build. It worked.

    I'll close this ticket due to this particular workaround, and because this is the only package we've had it happen on so far. However, I'm still very uneasy about the fact that nobody seems to have a clue why the recent change may have caused a "working configuration" to "stop working". Even if it "should not have been working in the first place"... somebody should be able to explain what change in the environment was "corrected"

    Please let me know if you come up with anything.

    Thanks again for sticking with this and helping us find this workaround. You guys really are great!

  20. Support Staff 20 Posted by Owen McDonnell on 06 Mar, 2018 07:17 AM

    Owen McDonnell's Avatar

    No problem, it's what we do...
    We're not comfortable with the breaking change either but its likely buried somewhere in recent updates which are needed by other customers. We'll leave it for now as long as you are not totally stuck, but keep our eyes peeled for any other possible manifestation of this unexpected behaviour.

  21. jerrywiltse closed this discussion on 15 Jun, 2018 12:35 PM.

  22. jerrywiltse re-opened this discussion on 15 Jun, 2018 12:37 PM

  23. 21 Posted by jerrywiltse on 15 Jun, 2018 12:37 PM

    jerrywiltse's Avatar

    For future ref, I don't know how this was fixed, but it seems to have just gone away and our builds work now.

  24. jerrywiltse closed this discussion on 15 Jun, 2018 12:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac