are you missing a using directive or an assembly reference?

Newnottakenname's Avatar


10 Dec, 2014 09:37 PM

So I am working on an app for windows phone and to learn how to use CI and just to getting to learn it, I used this to use service. It had its ups and down but it worked ! (for a while)

I tried to implent a BackgroundTask, to keep the app running in the background. For that purpose I created 2 new projects, SharedCode (for all the code) and BackgroundTask. It all works fine on my machine, however when trying to build the app on here, it fails. As far as I can tell, it seems that the problem is that either the build order of the projects is wrong or that they are not building at all.

As a reference: API,TvShow, and Episode are all classes that reside in SharedCode
I have double checked and Followshows(Main project) has references to BackgroundTask and SharedCode.

End result of building on local computer:
========== Build: 4 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

Thank you for reading,

  1. Support Staff 1 Posted by Feodor Fitsner on 11 Dec, 2014 04:28 AM

    Feodor Fitsner's Avatar

    I've tried building just SharedCode\SharedCode.csproj and oops: :)

  2. 2 Posted by Newnottakenname on 11 Dec, 2014 09:56 AM

    Newnottakenname's Avatar

    My bad, sorry has been fixed. link

    Build still fails, unfortunately. link

  3. 3 Posted by Newnottakenname on 21 Dec, 2014 10:59 AM

    Newnottakenname's Avatar

    Do you have any clue what causes the problem?

  4. Support Staff 4 Posted by Feodor Fitsner on 21 Dec, 2014 07:46 PM

    Feodor Fitsner's Avatar

    I don't think it's AppVeyor issue. I cloned the repo to a clean folder on my machine and got same errors while trying to build with msbuild. The issue is called "works on my machine" :)

  5. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:52 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac