Yarn build

Quentin Goinaud's Avatar

Quentin Goinaud

07 Mar, 2018 09:40 AM


When running yarn build or yarn run build on Windows, it's running fine.
But when running on the new Ubuntu, it's not doing anything:

yarn install v1.5.1
[1/4] Resolving packages...
⠁ [2/4] Fetching packages...
info fsevents@1.1.3: The platform "linux" is incompatible with this module.
info "fsevents@1.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
[4/4] Building fresh packages...
Done in 40.13s.
Running "build_script" scripts
yarn run build
Build exited with code 0
  1. Support Staff 1 Posted by Ilya Finkelshte... on 07 Mar, 2018 10:02 PM

    Ilya Finkelshteyn's Avatar

    Can you please share more details? Link to your build will not hurt. Also if repository is private, please share package.json file.

  2. 2 Posted by Quentin Goinaud on 07 Mar, 2018 10:16 PM

    Quentin Goinaud's Avatar

    Here is a link to the build: https://ci.appveyor.com/project/armaldio/addoninstaller/build/0.1.4...
    And here is alink to my repo on the branch where I have my changes: https://github.com/armaldio/AddonInstaller/tree/feature/appveyor-linux

    Many thanks!

  3. Support Staff 3 Posted by wasapl on 08 Mar, 2018 08:17 PM

    wasapl's Avatar


    Since "yarn install" command took 40 seconds to execute I believe it did install dependencies silently. You may run "yarn --verbose" to make it more chatty.
    Also you have node dependencies and they require certain version of node. On ubuntu image we have several versions of NodeJS preinstalled with NVM Node Version Manager (https://github.com/creationix/nvm). Please run "nvm use 6" to pick appropriate version of node before running "yarn" command.

    Please let me know if any of that helped or not.

  4. 4 Posted by armaldio on 08 Mar, 2018 08:54 PM

    armaldio's Avatar

    I'm not sure it's related to to the version of node
    The exact same build with the same configuration shows rougly the same outpout..untile yarn build

    You can compare
    Windows: https://ci.appveyor.com/project/armaldio/addoninstaller/build/0.1.4...
    Linux: https://ci.appveyor.com/project/armaldio/addoninstaller/build/0.1.4...

  5. Support Staff 5 Posted by Feodor Fitsner on 09 Mar, 2018 07:51 PM

    Feodor Fitsner's Avatar

    We are looking into that. The fix is coming in a day or so.

  6. Support Staff 6 Posted by Feodor Fitsner on 12 Mar, 2018 04:17 AM

    Feodor Fitsner's Avatar

    The issue with Yarn has been fixed. Please give it another try and let us know how t worked.

    There are still issues with rendering some ANSI escape codes though, but we are looking into that right now.

  7. 7 Posted by armaldio on 12 Mar, 2018 11:51 AM

    armaldio's Avatar

    The issue is fixed for me, everithing works as intended now. Thanks!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac