error MSB4066

Thiago Bertuzzi's Avatar

Thiago Bertuzzi

07 Mar, 2018 07:33 PM

Hello, help. when I run on my machine it works, but when I run the site, the following error is displayed:

Build started
2git clone -q --branch=master https://github.com/TBertuzzi/Xamarin.Forms.MultiSelectListView.git C:\projects\xamarin-forms-multiselectlistview
3git checkout -qf fa873e7fa3adb78d83a214c32195100e68d51119
4Patching .NET Core .csproj files
5Patching skipped for the following files: MultiSelectListViewSample\MultiSelectListViewSample.Android\MultiSelectListViewSample.Android.csproj, MultiSelectListViewSample\MultiSelectListViewSample.iOS\MultiSelectListViewSample.iOS.csproj, MultiSelectListViewSample\MultiSelectListViewSample.UWP\MultiSelectListViewSample.UWP.csproj, Xamarin.Forms.MultiSelectListView\Xamarin.Forms.MultiSelectListView.csproj. Reason is that presumably they are not .NET Core .csproj files.
6msbuild "C:\projects\xamarin-forms-multiselectlistview\Xamarin.Forms.MultiSelectListView.sln" /verbosity:quiet /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"
7Microsoft (R) Build Engine version 14.0.25420.1
8Copyright (C) Microsoft Corporation. All rights reserved.
9
10C:\projects\xamarin-forms-multiselectlistview\Xamarin.Forms.MultiSelectListView\Xamarin.Forms.MultiSelectListView.csproj(21,47): error MSB4066: The attribute "Version" in element <PackageReference> is unrecognized.
11Command exited with code 1

  1. 1 Posted by Jarl on 07 Mar, 2018 10:02 PM

    Jarl's Avatar

    Are you using the VS2017 image?

  2. 2 Posted by Thiago Bertuzzi on 13 Mar, 2018 11:52 AM

    Thiago Bertuzzi's Avatar

    I generated the code in the vs2017

  3. Support Staff 3 Posted by Ilya Finkelshte... on 13 Mar, 2018 05:37 PM

    Ilya Finkelshteyn's Avatar

    Thiago, Jarl asked if you use Visual Studio 2017 build worker image.

  4. 4 Posted by Thiago Bertuzzi on 13 Mar, 2018 06:31 PM

    Thiago Bertuzzi's Avatar

    Gotcha! Change to Visual Studio 2017 Image and works for me.

    But a new error : 'dontnet' is not recognized as an internal or external command,
    11operable program or batch file.
    12Command exited with code 1

    added dontnet restore src as before build script should :/

  5. 5 Posted by Thiago Bertuzzi on 13 Mar, 2018 07:10 PM

    Thiago Bertuzzi's Avatar

    Sorry .
    it was written wrong. Thanks a lot for the help

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac