Appveyor is building all branches when using "for" syntax

Daniel Toft's Avatar

Daniel Toft

09 Mar, 2018 10:56 AM


When I use the "for" syntax for sharing common configuration, it's seems that appveyor suddenly build all commits, and not only the commits in the branches I am watching on. It started to do this about 3 days ago. I'm using the bitbucket integration for watching on my repository. My configuration look like this:

version: 1.0.{build}
image: Visual Studio 2017
shallow_clone: true

... more defult configuration ...

      - staging
  configuration: Staging

    publish_wap: true

    - provider: Environment
      name: {name}

      - production
  configuration: Release
     APPVEYOR_WAP_ARTIFACT_NAME: $(project_name)-$(appveyor_build_version)

    publish_wap_xcopy: true
  1. Support Staff 1 Posted by Ilya Finkelshte... on 09 Mar, 2018 06:18 PM

    Ilya Finkelshteyn's Avatar

    Hi Daniel,

    This was actually a bug, for syntax is not supposed to restrict branches to build, its job is to to specialize configuration to specific branches. As you see this was fixed, which cause you a trouble. Sorry for that.

    To make it work as you need, you can add branches/only setting into default configuration part.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac