Appveyor is building all branches when using "for" syntax

Daniel Toft's Avatar

Daniel Toft

09 Mar, 2018 10:56 AM

Hi

When I use the "for" syntax for sharing common configuration, it's seems that appveyor suddenly build all commits, and not only the commits in the branches I am watching on. It started to do this about 3 days ago. I'm using the bitbucket integration for watching on my repository. My configuration look like this:


version: 1.0.{build}
image: Visual Studio 2017
shallow_clone: true

... more defult configuration ...


for:
-
  branches:
    only:
      - staging
  configuration: Staging
  

  build:
    publish_wap: true

  deploy:
    - provider: Environment
      name: {name}

-
  branches:
    only:
      - production
  configuration: Release
  
  environment:   
     APPVEYOR_WAP_ARTIFACT_NAME: $(project_name)-$(appveyor_build_version)

  build:
    publish_wap_xcopy: true
  1. Support Staff 1 Posted by Ilya Finkelshte... on 09 Mar, 2018 06:18 PM

    Ilya Finkelshteyn's Avatar

    Hi Daniel,

    This was actually a bug, for syntax is not supposed to restrict branches to build, its job is to to specialize configuration to specific branches. As you see this was fixed, which cause you a trouble. Sorry for that.

    To make it work as you need, you can add branches/only setting into default configuration part.

    Ilya.

  2. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac