Web deploy arhive store incorrect target folder for deployment project

ap's Avatar

ap

12 Mar, 2018 06:22 AM

Hi. We experinsed a problem from 5 march for one of our projects. We use MSBuild settings for project and "Package Web Applications for Web Deploy" settings for packing build to make deployment. From 5 march 2018 we started to see, that zip-archive with files to make web deploy has changes in the parameters.xml file. Before it (last normal build was at 02 March 2018) in the parameters.zip we had parameter with tag="IssApp" had defalutValue="Default Web Site/". From 05 march for same paramater we have other value: defaultValue="Default Web Site/<ourProjectName>_deploy". (I changed our real project name to <ourProjectName> in this example).
We didn't change anything in the settings of the our project, but have such changes. As the result of the such changes we deployed our new apps not in the root of the project, but in the sub-folder <ourProjectName>_deploy. And it create a some problems for our system.
Could you please explain, why it occurs?

  1. Support Staff 1 Posted by Ilya Finkelshte... on 12 Mar, 2018 07:45 PM

    Ilya Finkelshteyn's Avatar

    Sorry for the inconvenience. We found this bug (side effect of new AWS Elastic Beanstalk deployment feature) in the end of last week, fix is deployed today.
    Please let us know if you are OK now.

  2. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac