Cannot restart job

Richard Schneeman's Avatar

Richard Schneeman

19 Mar, 2018 04:36 PM

I've got commit on https://github.com/puma/puma however I cannot restart the appveyor builds. Here's a link to a failing build https://ci.appveyor.com/project/nateberkopec/puma/build/1.0.269

Here's a failing job https://ci.appveyor.com/project/nateberkopec/puma/build/1.0.269/job.... Here's what I see

I have my github account linked to my appveyor account. Any ideas?

  1. Support Staff 1 Posted by Ilya Finkelshte... on 19 Mar, 2018 10:35 PM

    Ilya Finkelshteyn's Avatar

    Richard,

    You are not user or collaborator in nateberkopec account. More info here.

    P.S. AppVeyor permissions are not exactly tied to GitHub ones as we support a lot of other version control systems like Gitbucket, GitLab, VSTS e.t.c.

    Ilya.

  2. 2 Posted by Richard Schneem... on 20 Mar, 2018 05:03 PM

    Richard Schneeman's Avatar

    Hi, the collaborator nateberkopec tried removing it and adding the repo again, but it still shows up under his account instead of under the puma organization.

    The nateberkopec is a personal user who cannot grant me access to all of his private repositories. How can we set this up so that everyone who has commit to puma can restart builds?

  3. Support Staff 3 Posted by Ilya Finkelshte... on 20 Mar, 2018 05:20 PM

    Ilya Finkelshteyn's Avatar

    I am not sure I understand what does 'puma' organization means. AppVeyor Account in question is nateberkopec. I do not see any other AppVeyor URLs in the original message, which point to any other AppVeyor account. If you need to be able to start builds in that account, account owner should make you a collaborator.

    I feel that here is a confusion between GitHub permission model and AppVeyor one. They are not toed, because AppVeyor supports many others version control systems like Bitbucket, GitLab e.t.c. This was the reason I sent this link in the original answer.

    Please let us know if this makes more sense now.

  4. 4 Posted by richard schneem... on 20 Mar, 2018 05:28 PM

    richard schneeman's Avatar

    The "puma" organization refers to http://github.com/puma/ it is not a
    person, but instead an organization. I have commit access to this
    organization. Nateberkopec is an individual, his personal projects are at
    github.com/nateberkopec. If he gave me access to `nateberkopec` then I
    would be able to modify any of his personal files and see his private
    repos, which is not what either of us wants. The puma project does not
    belong to `nateberkopec` on github, or it would be found at `
    github.com/nateberkopec/puma` instead it is at `github.com/puma/puma`.

    Nateberkopec set up the integration with appveyor for `github.com/puma/puma`
    because he is a maintainer of github.com/puma/puma which is in the
    github.com/puma organization. How do I set up the project so that everyone
    who has access to github.com/puma/puma can restart builds on appveyor?

  5. Support Staff 5 Posted by Ilya Finkelshte... on 20 Mar, 2018 05:32 PM

    Ilya Finkelshteyn's Avatar

    This can be done, as described here, however it will not be "everyone
    who has access to github.com/puma/puma", but members of specific team.

  6. 6 Posted by Richard Schneem... on 20 Mar, 2018 07:05 PM

    Richard Schneeman's Avatar

    Thanks for the link.

    I set up a new org https://ci.appveyor.com/project/puma/puma. I added myself as a co-administrator along with others, I also added a github team that i'm part of.

    But I'm still not seeing a "rebuild" or "restart" option when logged in under my normal github account. When I look at https://ci.appveyor.com/project/puma/puma/build/1.0.4/job/do0rwhpu8... as @schneems this is what I see:

  7. Support Staff 7 Posted by Ilya Finkelshte... on 20 Mar, 2018 07:28 PM

    Ilya Finkelshteyn's Avatar

    Hmm, I see that you are Collaborator with Administrator role so you should see those options. Can you try to sign off ant try to sign in again and select puma account and see if this helps.

  8. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac