Installing mingw with Chocolatey won't finish

florian.rival's Avatar

florian.rival

18 Jan, 2015 05:23 PM

Hey AppVeyor team,

I'm getting stuck when trying to make my software (GDevelop, an open source game creator) being built by AppVeyor.
The install script is simply composed of choco install mingw. But after executing this line, nothing happens and the build times out. It worked when I tried the first time, but somehow something broke! :O (In the first build, I also got this problem one time: after launching cmake, nothing happened until the timeout of the build).

Here is the link to the project: https://ci.appveyor.com/project/4ian/gd/build/1.0.18

Any idea on why it fails?

  1. Support Staff 1 Posted by Feodor Fitsner on 19 Jan, 2015 04:30 AM

    Feodor Fitsner's Avatar

    You could just use "unstable" build worker image with MinGW pre-installed.

  2. 2 Posted by florian.rival on 19 Jan, 2015 05:46 PM

    florian.rival's Avatar

    Thanks for your quick answer :)
    But I've tried with unstable without success :( This time the build hangs when launching CMake:
    https://ci.appveyor.com/project/4ian/gd/build/1.0.1

    (I've also deleted the project and created it again to make sure that it wasn't related to an old setting). I'm a bit stuck because I've not a single clue of why there isn't any output.

  3. Support Staff 3 Posted by Feodor Fitsner on 19 Jan, 2015 06:14 PM

    Feodor Fitsner's Avatar

    If it's stuck most probably it's asking for some input. Unfortunately, I'm not a specialist in C++ languages, so it's hard to suggest something specific here. Try to isolate the issue, do some simple test, etc.

  4. 4 Posted by florian.rival on 19 Jan, 2015 07:03 PM

    florian.rival's Avatar

    I got something working better: https://ci.appveyor.com/project/4ian/gd/build/1.0.3
    Compare it with: https://ci.appveyor.com/project/4ian/gd/build/1.0.2

    I remove the argument specifying to use MinGW and the one that was deleting a file. Yet it is strange that it make the build stuck because CMake is never asking for input (and always display at least some output). And I'm a bit suspicious because when I encountered the problem for the first time, it was with Chocolatey which worked before.

    Anyway, as the build is using VS2012 I've still to work to get something working with MinGW, stay tuned :)

  5. 5 Posted by tim on 28 Mar, 2015 12:29 PM

    tim's Avatar

    Hi,

    I've had the same problem trying to compile a C++ library, using the MinGW environment. it seems cmake execution hangs in one of the two cases:
    1) removing sh.exe from path https://ci.appveyor.com/project/timootei/cegui-dependencies-521/bui...
    2) executing cmake 2 times: https://ci.appveyor.com/project/timootei/cegui-dependencies-521/bui...

    Just to be clear, cmake does not require any form of user input, so it should work just fine.
    Is there any way we could troubleshot this? Maybe remote logging to the vm at that time and inspecting if there's potentially any crash?

    Thanks.

  6. Support Staff 6 Posted by Feodor Fitsner on 28 Mar, 2015 06:34 PM

    Feodor Fitsner's Avatar

    That "RemoteException" error is when app writes to StdErr and PowerShell considers that as an exception. Run your build commands as CMD.

  7. 7 Posted by tim on 28 Mar, 2015 09:03 PM

    tim's Avatar

    Hi,

    I've tried first PowerShell but in the end, it seems I got this working with CMD:

    • Environment: MinGW
    • settings PATH=C:\MINGW\bin\;%PATH%
    • execute cmake
    • Works fine!
  8. 8 Posted by florian.rival on 29 Mar, 2015 07:51 AM

    florian.rival's Avatar

    I confirm that I also managed to get CMake and the build running by tweaking the PATH to add =c:\mingw\bin (and only the paths I really need). :)

  9. Support Staff 9 Posted by Feodor Fitsner on 29 Mar, 2015 07:55 AM

    Feodor Fitsner's Avatar

    Great, thanks for the update!

    -Feodor

  10. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:55 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac