The build tools for v141 (Platform Toolset = 'v141') cannot be found

trejkaz's Avatar

trejkaz

04 May, 2018 04:49 AM

I get this error trying to set up a brand new build:

...
Project "C:\projects\MyProject\MyProject.sln" on node 1 (default targets).
ValidateSolutionConfiguration:
  Building solution configuration "Debug|x64".
The target "CopyLocalFilesOutputGroup" listed in a BeforeTargets attribute at "C:\Tools\vcpkg\scripts\buildsystems\msbuild\vcpkg.targets (80,82)" does not exist in the project, and will be ignored.
Project "C:\projects\MyProject\MyProject.sln" (1) is building "C:\projects\MyProject\MyProject\MyProject.vcxproj" (2) on node 1 (default targets).
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.Cpp.Platform.targets(57,5): error MSB8020: The build tools for v141 (Platform Toolset = 'v141') cannot be found. To build using the v141 build tools, please install v141 build tools.  Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting "Retarget solution". [C:\projects\MyProject\MyProject\MyProject.vcxproj]
Done Building Project "C:\projects\MyProject\PlayspMyProjectceMover\MyProject.vcxproj" (default targets) -- FAILED.
Done Building Project "C:\projects\MyProject\MyProject.sln" (default targets) -- FAILED.
Build FAILED.
...

I already tried a suggestion I found in another thread, adding /p:VisualStudioVersion=11.0 to the end of the command-line, which fails in an identical fashion.

I expected this project to break when it started looking for libraries but didn't really expect it to break right out of the gate like this, so I'm not sure what to do. If other people have hit the same error in the past, it surely can't be that the build tools are too new.

  1. 1 Posted by trejkaz on 04 May, 2018 04:50 AM

    trejkaz's Avatar

    Grumble, made a paste error in the formatting when I was editing out the real project name and now I can't edit the post to correct it. :(

  2. Support Staff 2 Posted by Owen McDonnell on 04 May, 2018 03:27 PM

    Owen McDonnell's Avatar

    Which image are you trying to build on? If not set it runs on Visual studio 2015 image and that wouldn't have the v141 toolset.
    Try running with image: Visual Studio 2017 in yaml configuration.

  3. 3 Posted by trejkaz on 06 May, 2018 11:16 PM

    trejkaz's Avatar

    Bingo, that's exactly what it was. I'm surprised I didn't find any existing posts about that when I searched, but I guess there's one now. :)

    Thanks

  4. Owen McDonnell closed this discussion on 07 May, 2018 08:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac