Cannot find package in NuGet gallery

Adam Ralph's Avatar

Adam Ralph

07 May, 2018 09:48 AM

This build says

C:\projects\liteguard\targets\Targets.csproj : error NU1102: Unable to find package Bullseye with version (>= 1.0.0-rc.1)

C:\projects\liteguard\targets\Targets.csproj : error NU1102: - Found 2 version(s) in nuget.org [ Nearest version: 1.0.0-alpha0002 ]

But the package is clearly in the gallery.

At first I thought this could just be a caching delay, but it's been almost 18 hours since I published that version of the package.

Could this be because the package has a SemVer 2.0 version (dot separated pre-release identifiers and build metadata)?

When I build locally, everything works (also after clearing the local machine package cache).

  1. 1 Posted by Adam Ralph on 07 May, 2018 10:31 AM

    Adam Ralph's Avatar

    I turned out that this was due to the wrong image being used. Although the UI is set to Visual Studio 2017, the presence of the YAML file means that that setting is not actually used. I fixed it by setting the image in the YAML. This is not the first time that this has tripped me up. Perhaps it would be good to make explicit and obvious which image is being used. Perhaps it should be viewable in the UI somehow, for each build?

  2. Adam Ralph closed this discussion on 07 May, 2018 10:31 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac