Qt 5.7 vanished overnight

trejkaz's Avatar

trejkaz

17 May, 2018 06:14 AM

Qt 5.7 used to live in C:\Qt\5.7\msvc2015_64 when using the Visual Studio 2015 image.

In fact, only yesterday I had a build succeed which was using it.

But today, it's completely gone. The current build environment shows it as not present on 2015:
https://www.appveyor.com/docs/build-environment/#qt

But when you look in the Google cache, you can see that it previously was on all images:
https://webcache.googleusercontent.com/search?q=cache:dIuUWPg2gWcJ:...

  1. Support Staff 1 Posted by Feodor Fitsner on 17 May, 2018 06:20 AM

    Feodor Fitsner's Avatar

    Correct, 5.7 was removed from the build image as it reached EOL: https://github.com/appveyor/ci/issues/2291

    We cannot keep every version of Qt on build worker image as it takes a lot (~15 GB per version).

    Switch your build to either 5.6.x or 5.9.x LTS.

  2. 2 Posted by trejkaz on 17 May, 2018 06:22 AM

    trejkaz's Avatar

    Oh my...

    I hope it still builds on 5.9, because I'm not familiar with the code, I'm just trying to get it to build.

    Maybe my idea of using the pre-installed Qt was mistaken in the first place though. It doesn't make for stable builds if the platform can suddenly remove things with no notice.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac