SVN Checkout does not complete in 40 minutes

mmiller's Avatar

mmiller

03 Feb, 2015 10:10 PM

I setup a SVN project today and tried to run the build twice. After 40 minute the first build timed out - the only thing in the log is this:

1 Build started
2 svn checkout -q https://subversion.assembla.com/svn/my-repository/ C:\projects\my-repository

I tried again and its at 22 minutes. Locally I can do a clean checkout in about a minute. Repository is about 50mb in size. Any ideas?

  1. Support Staff 1 Posted by Feodor Fitsner on 03 Feb, 2015 10:14 PM

    Feodor Fitsner's Avatar

    Is it failed after 22 minutes in the second time?

  2. 2 Posted by mmiller on 03 Feb, 2015 10:18 PM

    mmiller's Avatar

    It’s still running – but I think something is clearly wrong if it takes more than 20 minutes to checkout a 50mb repository. Does the log show any issues with connecting to SVN? Anyway to troubleshoot what’s happening?

  3. Support Staff 3 Posted by Feodor Fitsner on 03 Feb, 2015 10:19 PM

    Feodor Fitsner's Avatar

    I think it's wrong credentials. It's stuck because asking for credentials.

  4. 4 Posted by mmiller on 03 Feb, 2015 10:35 PM

    mmiller's Avatar

    Yep that was it - thanks. Probably need to have the log give a little more detail :)

  5. Support Staff 5 Posted by Feodor Fitsner on 03 Feb, 2015 10:38 PM

    Feodor Fitsner's Avatar

    Unfortunately, svn.exe gives nothing but just stalls.

  6. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:53 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac