Having problems with Web Deploy with untrusted server

Pure Krome's Avatar

Pure Krome

04 Feb, 2015 03:54 AM

Hi,

I'm trying to webdeploy to our custom IIS vm in Azure.

When i connect to it -manually- (eg. in Visual Studio to check / verify my creds) i get a pop saying the SSL cert is not trusted, blah blah blah. Message is legit and correct.

I thought there was a way to tell msdeploy to accept untrusted ssl's?

eg.

Web.deploy.cmd
  /Y
  /M:https://AutoDeploy:8172/MsDeploy.axd
  -allowUntrusted
  /U:AutoDeploy\Administrator
  /P:Passw0rd
  /A:Basic

reference : Troy Hunt's blog post.

Is there a way we can do this? If not, could i manually fire off msdeploy.exe myself for a custom deploy command?

  1. Support Staff 1 Posted by Feodor Fitsner on 04 Feb, 2015 03:58 AM

    Feodor Fitsner's Avatar

    You can call any command for sure.

    Why wouldn't you use built-in deployment provider?

  2. 2 Posted by Pure Krome on 04 Feb, 2015 04:00 AM

    Pure Krome's Avatar

    because there's no checkbox to do -allowUntrusted ... or is there?

    (the build-in MSDeploy provider works 100000% sweet with our production azure websites. but for our dev sites (ie. the developers who's forks continuously deploy to their iis website on a single azure vm) i'm stuck trying to get this to work :(

  3. 3 Posted by Pure Krome on 04 Feb, 2015 04:01 AM

    Pure Krome's Avatar

    Also - what's the command line if i have to? msdeploy.exe is the name? or web.deploy.cmd ... ?

  4. Support Staff 4 Posted by Feodor Fitsner on 04 Feb, 2015 04:02 AM

    Feodor Fitsner's Avatar

    Built-in Web Deploy provider should allow untrusted certificates.

    msdeploy.exe - it's installed on build workers, but not in PATH

  5. 5 Posted by Pure Krome on 04 Feb, 2015 04:13 AM

    Pure Krome's Avatar

    Built-in Web Deploy provider should allow untrusted certificates.

    hmmm. ok. then i must have another issue then if you're already doing that bit, for us :(

    It just hangs here...

    Uploading artifact Foo.zip (24.3 MB)...OK
    Deploying using WebDeploy provider
    Synchronizing contents of "Foo.Application.Web" artifact to website Dev-Web on server https://foo.cloudapp.net:8172/msdeploy.axd?site=Dev-Web using WebDeploy
    Info: Using ID '3dde7e44-6421-4113-afa5-ef81dbec6a38' for connections to the remote server.
    

    Hard to test this stuff :(

    Is there any chance u might be able to update the AV MSDeploy docs to list the actual msdeploy command line that is ran, just for reference please?

  6. Support Staff 6 Posted by Feodor Fitsner on 04 Feb, 2015 04:31 AM

    Feodor Fitsner's Avatar

    The trick is that it doesn't use msdeploy.exe command line, but it uses managed Web Deploy API.

    If you manage to deploy this from command line using msdeploy.exe then you should be able to use the same settings in AV.

  7. 7 Posted by Pure Krome on 04 Feb, 2015 04:53 AM

    Pure Krome's Avatar

    Got it working in AV with UI. I'm guessing the problem was with my Web Management Service. Restarting that and it all worked.

    Sorry for wasting your time :(

  8. 8 Posted by Pure Krome on 04 Feb, 2015 04:53 AM

    Pure Krome's Avatar

    Ref:

  9. Pure Krome closed this discussion on 04 Feb, 2015 04:53 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Aug, 2019 11:06 PM
21 Aug, 2019 02:08 PM
21 Aug, 2019 01:37 PM
21 Aug, 2019 10:21 AM
21 Aug, 2019 09:10 AM

 

21 Aug, 2019 05:56 AM
21 Aug, 2019 03:08 AM
20 Aug, 2019 11:33 PM
20 Aug, 2019 08:07 PM
20 Aug, 2019 05:50 PM
20 Aug, 2019 12:35 PM