Can't deploy a ZIP artefact to GitHub

Andrii Melnykov's Avatar

Andrii Melnykov

04 Jul, 2018 09:21 PM

I have the following in my .appveyor.yaml:

artifacts:
  - path: PARs
    name: pars_zip
    type: zip

Note that I can't create ZIP type artefacts from the UI. The artefact is created and can be seen/downloaded under artefacts

However when I try to deploy it doesn't work. Apparently it doesn't recognize pars_zip as an artefact.

  1. 1 Posted by Andrii Melnykov on 04 Jul, 2018 09:27 PM

    Andrii Melnykov's Avatar

    Apparently there are 2 places:

    • Environments from the top menu
    • Projects - Settings - Deployment

    They look the same but apparently only the former one works. What is the second one for?

  2. Support Staff 2 Posted by Ilya Finkelshte... on 04 Jul, 2018 09:33 PM

    Ilya Finkelshteyn's Avatar

    Please check the difference between Inline and Environment deployments here.

    As I understand Inline does not works for you. Send your build configuration in YAML format and link to the problem build so we can help.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac