coveralls - 422 - Unprocessable Entity

kasper's Avatar

kasper

09 Feb, 2015 04:44 PM

Using coveralls.io from .Net I can run opencover and then submit the coverages to www.coveralls.io

however, when i run inside appveyor i get the following error message

 Commit: 2593b7bd176a560027f42b8d4c17b609771be9d3
Error sending to Coveralls.io (422 - Unprocessable Entity
Command exited with code 1

My configuration can be found here

https://github.com/kbilsted/StatePrinter/blob/feature/codecoverage/appveyor.yml

I already have verbosity: detailed so not sure how to get more detailed error messages

  1. Support Staff 1 Posted by Feodor Fitsner on 09 Feb, 2015 08:48 PM

    Feodor Fitsner's Avatar

    "Unprocessable Entity" looks like a response from coveralls side. Have you tried asking their support about this?

    -Feodor

  2. 2 Posted by kasper on 11 Feb, 2015 05:07 PM

    kasper's Avatar

    Can i somehow SSH into the machine so to inspect the content of the file that fails?

  3. Support Staff 3 Posted by Feodor Fitsner on 11 Feb, 2015 05:15 PM

    Feodor Fitsner's Avatar

    Nope (right now - but it's a feature for future releases), but you can push that file to artifacts.

  4. 4 Posted by kasper on 14 Feb, 2015 11:16 PM

    kasper's Avatar

    I tracked the problem down to that I had also set the environment variable using the "Environment" configuration of the project. The content of this variable, however, was an old (and thus unusable security token).

    Appveyor should complain if a variable in a .yml tries to override the project configuration. Or, I would have expected the .yml file to overrule the configuration.

  5. Support Staff 5 Posted by Feodor Fitsner on 14 Feb, 2015 11:42 PM

    Feodor Fitsner's Avatar

    Thanks for the update! Glad you resolved the issue.

    Currently, it's made so environment variables defined on UI merges and overrides with those ones defined in appveyor.yml.

  6. 6 Posted by harel.mazor on 14 Apr, 2017 11:46 PM

    harel.mazor's Avatar

    I have an issue which isn't the same but the topic fits.
    I send data to coveralls.io and I get a 200 response but the data is not presented in coveralls.io site.
    When running the same command line from local powershell everything is working as expected.
    I'm not sure how to proceed.
    This is the coverall repo:
    https://coveralls.io/github/IsraelHikingMap/Site
    This is the relevant build:
    https://ci.appveyor.com/project/HarelM/site

    The last few lines of the build is where I send the data to coveralls using coverall.net which gives a successful log message.
    Any ideas what I need to check and how?

  7. Support Staff 7 Posted by Ilya Finkelshte... on 15 Apr, 2017 12:15 AM

    Ilya Finkelshteyn's Avatar

    I would connect with RDP and test command with minimum number of options and simplest file to upload and the progress to the full command.

    Note however that RDP session does not AppVeyor environment variables so you need to print them (except secure ones) during the build to use in RDP session.

    Speaking of secure environment variables, are you sure you need to print command and expose coveralls repo token? Making thread private if you want to fix this before I make it public back.

  8. 8 Posted by harel.mazor on 15 Apr, 2017 12:27 AM

    harel.mazor's Avatar

    Thanks, I'll try the RDP stuff tomorrow, I was not aware of this option.
    Well, this is a token for coveralls, I don't think it's that important that it needs to be hidden, I prefer to have the option to reproduce the issue if it happens instead of hiding this data...

  9. Support Staff 9 Posted by Ilya Finkelshte... on 15 Apr, 2017 12:29 AM

    Ilya Finkelshteyn's Avatar

    OK, making public. Let us know what you find. Maybe results you are uploading are not the same as on your local machine, try simpler results file.

  10. 10 Posted by harel.mazor on 15 Apr, 2017 08:57 AM

    harel.mazor's Avatar

    Can't figure this out, need your help:
    When I RDP to the machine and run the same command line from either cmd or powershell ISE the same files the build process created are uploaded to coveralls.io but when the regular build process it doesn't work... :-(
    I don't know how to further debug this, maybe record with fiddler when the build process runs? but then I need a build agent that had fiddler installed on it or something...?

  11. 11 Posted by harel.mazor on 16 Apr, 2017 09:11 PM

    harel.mazor's Avatar

    Can any of you help me? I really don't know how to proceed with this issue...

  12. Support Staff 12 Posted by Ilya Finkelshte... on 17 Apr, 2017 04:54 PM

    Ilya Finkelshteyn's Avatar

    To use Fiddler you can set blocking RDP in both install and on_finish part. Install Fiddler manually and start it, then delete blocking file and let build go. On finish new blocking RDP statement will let you check the results.

    However as a next step I propose less time consuming step. Try to run csmacnz.Coveralls.exe command with all parameters, outside of the .ps1 script and as cmd. If not all variables are available outside of the .ps1 script, then hard-code values. For beginning we just need to see how it works outside of script.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac