$ErrorActionPreference seems to reset to 'Stop'

xeijin's Avatar

xeijin

09 Aug, 2018 09:47 PM

Hello,

I am using a powershell script to install a number of components using a utility called scoop (www.scoop.sh) itself comprised of powershell scripts.

The install script runs fine on my local Windows 10 machine in powershell, but once I tried the same script in AppVeyor the build was failing with what look like terminating errors (even though these aren't terminating on my local machine).

So I set $ErrorActionPreference = 'Continue' (which I didn't have to do on my local machine) to try and force it to continue - this worked, to an extent, but now with particular apps (e.g. installing WinPython) the $ErrorActionPreference seems to reset and I get the following error which terminates the build (pip install superset was the originating command):

Adding superset to Pipfile's [packages]...
The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Pipfile.lock (ca72e7) out of date, updating to (34bbda)...

Note that the last line "Pipfile.lock..." is not even an error - simply a regular console message?

This particularly seems to be the case when the installer calls another executable e.g. pip but also eclipsec.exe when updating plugins for an application called KNIME Analytics Platform.

Anyone know what's up here, or even why AppVeyor might not be behaving like my local PowerShell?

  1. 1 Posted by xeijin on 09 Aug, 2018 09:50 PM

    xeijin's Avatar
  2. 2 Posted by xeijin on 11 Aug, 2018 11:31 AM

    xeijin's Avatar

    Further investigation: If I RDP into the VM during the build, then run the script from a PowerShell console, the issue does not occur -- does anyone know what AppVeyor is doing differently when it executes my script via the web interface?

  3. Support Staff 3 Posted by Owen McDonnell on 12 Aug, 2018 03:17 PM

    Owen McDonnell's Avatar

    Sorry for the delay, I forked your repo and tried running some builds to investigate but did not reach a conclusion yet.
    But upon picking up the matter today I see that several of your recent builds are succeeding.
    Did you find a solution to this problem?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac