Build failure on Win32 with

jslee02's Avatar

jslee02

17 Feb, 2015 02:58 AM

Hello,

I'm testing my project on Win32 and x64, but getting build failures on Win32.

The build stops throwing a message Command exited with code 1. There was no error messages that explains what's the problem.

I tested my project on linux and windows but couldn't get any complains.

In MESSAGES tab, there is one warning from outside of my code, which is ..\..\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include\xstddef. But I'm not sure whether this is the cause.

Is there a way to get more detailed error messages? Please let me know what can I do to fix this build error.

Best,
Jeongseok

  1. 1 Posted by jslee02 on 17 Feb, 2015 03:00 AM

    jslee02's Avatar

    My tests were done on local computers.

  2. Support Staff 2 Posted by Feodor Fitsner on 17 Feb, 2015 03:28 AM

    Feodor Fitsner's Avatar

    Look at the attached comparison. On the left is successful build, on the right - failed.

    If AppVeyor detects "Visual Studio 2013" header in .sln file then it uses MSBuild 12.0, otherwise it's MSBuild 4.0 which is in PATH. Either override msbuild in PATH or explicitly specify build command with MSBuild 12.0

  3. 3 Posted by jslee02 on 17 Feb, 2015 04:03 AM

    jslee02's Avatar

    Thank you for the quick answer!

    I got the point. It seems works now with explicit specification of MSBuild 12.0.

    I have a following follow-up question. Can I make .sln file to specify "Visual Studio 2013" header? I'm using cmake to generate the .sln file.

  4. 4 Posted by jslee02 on 17 Feb, 2015 04:14 AM

    jslee02's Avatar

    Sorry, please ignore the previous post.

    MSBuild 12.0 also failed to build.

    Here is the build script I used:

    build_script:
      - cmd: cmd /C ""C:\Program Files (x86)\MSBuild\12.0\bin\msbuild.exe" "C:\projects\dart\build\dart.sln" /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll" /verbosity:detailed"
    
  5. Support Staff 5 Posted by Feodor Fitsner on 17 Feb, 2015 04:22 AM

    Feodor Fitsner's Avatar

    I'm afraid I run out of ideas. There were no major changes into build worker image recently, except updated CMake. And it was on Februry 12, but I see  from history last successful build was 3 days ago, after that.

    -Feodor

  6. Support Staff 6 Posted by Feodor Fitsner on 17 Feb, 2015 04:29 AM

    Feodor Fitsner's Avatar

    Seems it was initially broken here: https://ci.appveyor.com/project/jslee02/dart/build/619 then there were few successful builds.

    -Feodor

  7. 7 Posted by jslee02 on 17 Feb, 2015 04:49 AM

    jslee02's Avatar

    I think the failure started here.

    The strange part is that the build error does not rise on my local computer. Just Appveyor Win32 failed. So I'd like to get the detailed build log from BSBuild but don't know how. Setting verbosity: detailed didn't work. It still didn't throw any messages.

  8. Support Staff 8 Posted by Feodor Fitsner on 17 Feb, 2015 05:40 PM

    Feodor Fitsner's Avatar

    Try checking if the last successful build could be re-produced. Go to project history then open last successful build and click "Re-build commit" button.

  9. 9 Posted by jslee02 on 17 Feb, 2015 09:07 PM

    jslee02's Avatar

    I finally figured out how to resolve the build error.

    As I mentioned in the main post, there was a warning about signed/unsigned mismatch from at ....\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include\xstddef. I don't think the VS has defective code so I fixed all the signed/unsigned mismatches in my code. Now the build error is gone.

    As I known, singed/unsigned mismatch causes warning but not error. I still don't know how the signed/unsigned mismatch cause the build error since there is no error message here. So I still would like to know how to get more detailed build log.

  10. Support Staff 10 Posted by Feodor Fitsner on 17 Feb, 2015 09:40 PM

    Feodor Fitsner's Avatar

    Remove AppVeyor logger from msbuild command line.

    -Feodor

  11. 11 Posted by jslee02 on 17 Feb, 2015 10:56 PM

    jslee02's Avatar

    Thanks Feodor! I could get detailed build log after removed AppVelyor logger. Now build continues even though there is signed/unsigned mismatch warning.

    Now I wonder why same code got crashed with AppVeyor logger.

  12. Support Staff 12 Posted by Feodor Fitsner on 18 Feb, 2015 05:58 AM

    Feodor Fitsner's Avatar

    That's hard to tell. Maybe some racing condition stuff.

  13. 13 Posted by jslee02 on 18 Feb, 2015 06:11 AM

    jslee02's Avatar

    Got it. Anyways, I had hard time with issue but it's resolved now. And it's good to know useful things about AppVeyor. I appreciate your help.

    Closing this discussion.

  14. jslee02 closed this discussion on 18 Feb, 2015 06:11 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac