Problem with encodable characters in artifact name such as plus

jcw's Avatar

jcw

15 Mar, 2014 05:28 AM

Hello,

I'm following the full semantic version spec (http://semver.org), which includes a part for build metadata. This is included after a plus sign, like this:

CIVersionTest-v1.0.0+6.unstable.git3d7d41e3.zip

It appears that attempting to create an artifact with a name that includes a plus sign (I also tried using %3b) results in a 404 not found.

Details:

This worked:

Push-AppveyorArtifact
C:\projects\test2\CIVersionTest\bin\CIVersionTest-v1.0.0.zip
CIVersionTest-v1.0.0.zip

This worked (note I'm using "t" instead of "+"):

Push-AppveyorArtifact
C:\projects\test2\CIVersionTest\bin\CIVersionTest-v1.0.0.zip
CIVersionTest-v1.0.0t7.unstable.git3d7d41e3.zip

This resulted in an error:

Push-AppveyorArtifact
C:\projects\test2\CIVersionTest\bin\CIVersionTest-v1.0.0.zip
CIVersionTest-v1.0.0+6.unstable.git3d7d41e3.zip

Exception calling "AddArtifact" with "4" argument(s): "The remote server returned an error: (404) Not Found."
At C:\Program Files\AppVeyor\BuildAgent\agent-api.psm1:184 char:5
+     [Appveyor.BuildAgent.Api.BuildServices]::AddArtifact($fullPath, $FileName, $ ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
+ FullyQualifiedErrorId : WebException

Command executed with exception

For now I'm just going to use a different character instead of plus in the zip file name, but if this ever fixed let me know and I'll switch it to using a plus so it matches the semantic version used throughout the rest of the system, thanks!

  1. Support Staff 1 Posted by Feodor Fitsner on 15 Mar, 2014 03:41 PM

    Feodor Fitsner's Avatar

    Nice issue. I will look into this, thank you!

  2. Support Staff 2 Posted by Feodor Fitsner on 16 Mar, 2014 03:42 AM

    Feodor Fitsner's Avatar

    OK, + is now supported in file names. Give it another try and let me know how it goes.

  3. 3 Posted by jcw on 16 Mar, 2014 06:22 AM

    jcw's Avatar

    Confirmed fixed. Thanks, I appreciate the quick turnaround time!

  4. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:38 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac