Uploading artifacts

dmitriy.litichevskiy's Avatar

dmitriy.litichevskiy

04 Sep, 2018 01:04 PM

Hello!
I have a problem during uploading build artifacts (NuGet packages) to storage, I got message

Error uploading artifact the storage: Remote server returned 500: Internal Server Error

for several times on Ubuntu. Example here: https://ci.appveyor.com/project/litichevskiydv/webinfrastructure/build/300/job/2q77n210iudym3ik.

  1. Support Staff 1 Posted by Owen McDonnell on 04 Sep, 2018 03:50 PM

    Owen McDonnell's Avatar

    Can you try adding APPVEYOR_BUILD_ARTIFACT_STORAGE environment variable with the value gce-artifacts-us to the environment variables of your Ubuntu build only and see if that yield a successful artifact upload.

  2. 2 Posted by dmitriy.litiche... on 04 Sep, 2018 04:26 PM

    dmitriy.litichevskiy's Avatar

    I've just tried and it works (https://ci.appveyor.com/project/litichevskiydv/webinfrastructure/build/307/job/8wytu4c51erk338s). Should I keep this environment variable?

  3. Support Staff 3 Posted by Owen McDonnell on 04 Sep, 2018 05:55 PM

    Owen McDonnell's Avatar

    Yes, but it should only be necessary until this issue is sorted out.

  4. Ilya Finkelshteyn closed this discussion on 04 Nov, 2018 09:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac