npm install --global fails on Ubuntu with Node 6

azizatif+appveyor's Avatar

azizatif+appveyor

13 Sep, 2018 04:17 PM

I am running npm install -g eclint on the Ubuntu image but it keeps failing partway through the installation process. There is no error from NPM itself but the build fails due to an exit code of 1. The funny thing is that the same commit can be re-built and that installation fails at a different spot along the installation progress. You can see this in in build 143 and 145 of my project. I tried the npm install -g eclint command in the node:6.14.4-alpine docker image and it worked without the error exit code.

Appreciate any help or pointers.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2018 10:37 PM
23 Oct, 2018 08:45 PM
23 Oct, 2018 07:48 PM
23 Oct, 2018 06:50 PM
23 Oct, 2018 06:06 PM