Database Project Fails to Compile

doug's Avatar

doug

10 Mar, 2015 10:46 PM

I have three database projects total. Two of the three will compile successfully using

msbuild "Path_to_project" /t:Build /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll" /verbosity:q
but the third project fails with errors like "Invalid object name." All three compile locally.

The log output of the build is attached.

  1. Support Staff 1 Posted by Feodor Fitsner on 10 Mar, 2015 11:04 PM

    Feodor Fitsner's Avatar

    Hi Doug,

    It's really hard to tell what's wrong with 3rd project from a build log. Do you think something is missing on build workers? Have you tried building locally from scratch (create clean folder, clone repo and build from there)?

  2. 2 Posted by doug on 11 Mar, 2015 12:04 AM

    doug's Avatar

    I have. I ran the same exact msbuild command as above. When compiling locally I will get the same amount of warnings but no errors. The only requirement for the project is SQL Server Data Tools, which would have to be installed since the other two projects build just fine.

  3. Support Staff 3 Posted by Feodor Fitsner on 11 Mar, 2015 12:20 AM

    Feodor Fitsner's Avatar

    Yes, there is Visual Studio 2013 Community Edition with Update 4 which has SSDT on board. Maybe you could try running it with more detailed logging?

  4. 4 Posted by doug on 11 Mar, 2015 10:25 PM

    doug's Avatar

    I ran the build again with diagnostic logging. Nothing new was revealed to me. I have double checked that all files are checked in and available on the build server. The only other issue I've noticed is on the dev machine I will get a warning when opening the project about the memory store being exceeded, but it is just a warning. Is it possible the build server will need to be larger to accommodate the project?

    I'm making the discussion public so the account holder can join in.

  5. Support Staff 5 Posted by Feodor Fitsner on 11 Mar, 2015 10:43 PM

    Feodor Fitsner's Avatar

    If it needs more memory try running it on "unstable" build worker image (Environment tab of project settings or "os: unstable" in appveyor.yml). Any custom image will make build running on Azure Medium instances with 3.5 Gb of RAM.

    -Feodor

  6. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:54 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac