Upload artifact to existing github release

Florian Franzen's Avatar

Florian Franzen

11 Mar, 2015 06:49 AM

I work with another CIs for on of my projects so whenever a tag is pushed, it might happen that the other CI is done building and uploading its artifact first and as a result appveyor does not upload anything.

It complains that "Release "<tagname>" already exists.", which is correct, but on the other hand should not be a problem. User that use the github interface to publish new releases and expect appveyor to build their release for them will also run into this problem, by the way. Github releases always trigger a tag creation, but appveyor will be unable to upload its artifacts because of the same error.

Is there any way around this limitation. I would like to avoid writing my own deployment script. Thank you in advance for your support.

  1. Support Staff 1 Posted by Feodor Fitsner on 11 Mar, 2015 08:10 PM

    Feodor Fitsner's Avatar

    Hi Florian,

    Actually, that is not a complaint but a warning and AppVeyor goes ahead and upload artifacts to the existing release. The process is not terminated if release already exists.

  2. 2 Posted by Florian Franzen on 12 Mar, 2015 03:53 PM

    Florian Franzen's Avatar

    Hi Feodor.

    Ok, I understand. I thought the "No artifacts were published. Make sure you have specified correct artifacts filter." was related to the message.

    I checked the config again and thought the problem was that I should have used "artifact: neuroscope-.*-win64\.exe" instead of "artifact: neuroscope-*-win64.exe", but still no luck. The documentation states after all that I have to use a proper regular expression.

    It still misses to upload the generated file "C:/projects/neuroscope/neuroscope-2.0.0-win64.exe".

    Any ideas on how to get the deployment working? Do I have to specify the absolute path?

    Thanks a lot,
    Florian

  3. Support Staff 3 Posted by Feodor Fitsner on 12 Mar, 2015 04:52 PM

    Feodor Fitsner's Avatar

    Surround regex with //:

    artifact: /neuroscope-.*-win64\.exe/
    
  4. 4 Posted by Florian Franzen on 16 Mar, 2015 12:20 PM

    Florian Franzen's Avatar

    I did that....
        https://github.com/neurosuite/neuroscope/blob/master/.appveyor.yml

    ... but it still does not upload anything:
        https://ci.appveyor.com/project/FloFra/neuroscope/build/v2.0.0-master-9

    I ran the exact same code on my Windows build machine and the file I filter for is there, so I can only assume the deployment script is to blame. I am out of ideas. Any hints what I might be doing wrong?

    Thank you in advance,
    Florian

  5. Support Staff 5 Posted by Feodor Fitsner on 16 Mar, 2015 12:23 PM

    Feodor Fitsner's Avatar

    The build has no artifacts: https://ci.appveyor.com/project/FloFra/neuroscope/build/v2.0.0-mast...

    You should package/push artifacts and then deploy them: http://www.appveyor.com/docs/packaging-artifacts

  6. 6 Posted by Florian Franzen on 18 Mar, 2015 01:44 PM

    Florian Franzen's Avatar

    Oh, I see. Should have read the documentation more carefully. I feel kind of dumb now. ;-)

    Thanks a lot for the great support. Everything works as expected now.

  7. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:55 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac