C1083 cannot open include file

jjplay175's Avatar

jjplay175

20 Oct, 2018 07:13 PM

I've pushed over 40 commits and spent hours on this but I am unable to get my project to build that uses SDL2. I can't for the life of me figure out how to get it work... I even tried moving my original SDL2 into my project

```
  c:\projects\project-n2de\2d_engine\2d_gameengine\game.h(4): fatal error C1083: Cannot open include file: 'SDL.h': No such file or directory [C:\projects\project-n2de\2D_Engine\2D_GameEngine\2D_GameEngine.vcxproj]```

---------------------------------
The file seems to be wrong so here is the code

====================
configuration: Release

image: Visual Studio 2017

environment:
  SDL2_IDIR: c:\mylibs\include\SDL2

install:
  - mkdir %SDL2_IDIR%
  - cd %TEMP%
  
  # SDL2
  - |-
    %DEPENDS% appveyor DownloadFile https://www.libsdl.org/release/SDL2-devel-2.0.8-VC.zip
    %DEPENDS% appveyor DownloadFile https://www.libsdl.org/projects/SDL_image/release/SDL2_image-devel-2.0.3-VC.zip
    %DEPENDS% 7z x SDL2-devel-2.0.8-VC.zip > nul
    %DEPENDS% 7z x SDL2_image-devel-2.0.3-VC.zip > nul
    %DEPENDS% copy SDL2-2.0.8\include\* %SDL2_IDIR% > nul
    %DEPENDS% copy SDL2_image-2.0.3\include\* %SDL2_IDIR% > nul
    %DEPENDS% copy SDL2-2.0.8\lib\x86\* %LIBDIR% > nul
    %DEPENDS% copy SDL2_image-2.0.3\lib\x86\* %LIBDIR% > nul
  
build:
  verbosity: normal

  1. Support Staff 1 Posted by Owen McDonnell on 22 Oct, 2018 06:33 PM

    Owen McDonnell's Avatar

    Have you tried accessing the build worker via rdp to make sure that your copying of folder contents to the project directory is working as expected?

  2. 2 Posted by jjplay175 on 23 Oct, 2018 07:15 PM

    jjplay175's Avatar

    I'm not familiar with it but I will do some research to see if I can get more information through that

  3. 3 Posted by jjplay175 on 23 Oct, 2018 07:48 PM

    jjplay175's Avatar

    On the remote desktop I opened VS and it built the game successfully

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • appveyor_1_.yml 50 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac