New builds not queuing correctly

tfoote's Avatar

tfoote

13 Mar, 2015 05:52 PM

Every time I try to trigger a new build manually. It tells me: "Build version 1.0.5 already exists."

Which is true: https://ci.appveyor.com/project/tfoote/ros2-batch-ci/build/1.0.5

When I added a commit to try triggering that way it registered a new build with the same number. See the history here: https://ci.appveyor.com/project/tfoote/ros2-batch-ci/history

And it failed in "0 ms" and looking at the content it's the same as the previous builds content.

  1. Support Staff 1 Posted by Feodor Fitsner on 13 Mar, 2015 06:09 PM

    Feodor Fitsner's Avatar

    Open General tab of project settings and increment build number. That should help. Looks like some database concurrence issue - will take a look.

  2. 2 Posted by tfoote on 13 Mar, 2015 06:20 PM

    tfoote's Avatar

    I found the solution. In the settings the "Next Build Number" was set to 5 not 6.

    I think the problem is that I had the settings open during a build, watched it fail, then tweaked the settings and tried to build again. However I did not reload the settings page after triggering the build, so the build number did not auto increment when I saved the settings, it rolled the build number down.

    It seems this sort of state should not be contained in the settings page. It's not in the appveyor.yml and can only cause conflicts. Is there a reason that this does not just auto increment every time?

  3. Support Staff 3 Posted by Feodor Fitsner on 13 Mar, 2015 06:28 PM

    Feodor Fitsner's Avatar

    Well, you can "reuse" this counter, like 1.0.1, 1.0.2, 1.0.3, then change version template and reset build number to have 2.0.1, 2.0.2, 2.0.3, etc.

  4. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:54 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac