BinTray Deployment Error

xeijin's Avatar

xeijin

26 Oct, 2018 10:13 AM

Hello,

When trying to deploy to BinTray I am presented with the following error, would you be able to advise on the issue?

Deploying using BinTray provider 
Uploading "propositum.tar.7z.001" to BinTray as xeijin/propositum/propositum/1.0.198/propositum.tar.7z.001...
No MediaTypeFormatter is available to read an object of type 'JObject' from content with media type 'text/plain'.

Full Build Log: https://ci.appveyor.com/project/xeijin/propositum/builds/19816917

Thanks,

  1. Support Staff 1 Posted by Owen McDonnell on 26 Oct, 2018 11:12 PM

    Owen McDonnell's Avatar

    I think your artifact should be a zip package. You can zip them before as described here and if necessary set explode: true in config.

  2. 2 Posted by xeijin on 11 Nov, 2018 10:29 PM

    xeijin's Avatar

    Unfortunately I'm still getting the same error, even with a 'zip' archive:

    https://ci.appveyor.com/project/xeijin/propositum#L4539

    Is it possible to change the 'media type' from text/plain somehow?

  3. Support Staff 3 Posted by Owen McDonnell on 13 Nov, 2018 05:37 AM

    Owen McDonnell's Avatar

    I don't see the same error. Can you point to a specific build?

  4. Ilya Finkelshteyn closed this discussion on 13 Jan, 2019 09:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac