Linker problem compiling with Clang 7

sunspear's Avatar


31 Oct, 2018 07:56 AM

I've been trying to compile open62541 with Clang under Windows but I can't fix an issue with the linker.


I tried a lot of different approaches, but none of them works.
I suspect that I missed something.

I attach the appveyor.yml I use.

  1. Support Staff 1 Posted by Owen McDonnell on 06 Nov, 2018 07:42 PM

    Owen McDonnell's Avatar

    Sorry for the delay in responding.
    Do you believe the issue is specific to AppVeyor? That is, do you have a local environment that builds this source code under similar conditions?

  2. 2 Posted by sunspear on 07 Nov, 2018 06:50 AM

    sunspear's Avatar

    I don't know if the issue is specific to AppVeyor.
    I don't have a local environment that builds.

    I see that some users are able to build with clang-cl in AppVeyor, but none of the suggested settings works with this project.

  3. Support Staff 3 Posted by Ilya Finkelshte... on 07 Nov, 2018 11:07 PM

    Ilya Finkelshteyn's Avatar

    First I would find some baseline, like last successful build. It seems that it is this one. I would re-run it (RE-BUILD COMMIT button in UI) and ensure it still works. If yes, check next failed build and try to understand the difference made by respective commit.

    Another baseline can be the appveyor.yml in the open62541/open62541 repository, from which your one is forked and which builds OK on AppVeyor.

  4. 4 Posted by sunspear on 08 Nov, 2018 09:26 AM

    sunspear's Avatar

    The problem is that my modification is to add a new job to AppVeyor (clang-cl).
    And this job fails.
    All the old jobs works.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • appveyor.yml 4.55 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac