Appveyor build fails whereas local build succeeds

godrose's Avatar

godrose

16 Nov, 2018 02:39 PM

The cloud build for the project Solid - https://github.com/godrose/Solid fails with DuplicateAttribute errors. The local build is just fine.
I use VS 15.9.1 locally. Could this be a problem?

  1. Support Staff 1 Posted by Owen McDonnell on 16 Nov, 2018 05:02 PM

    Owen McDonnell's Avatar

    It seems that it is only the v2.0.0 branch that is failing and which also has the AssemblyVersionAttribute field added to the AssemblyInfo.cs file. Is it possible that you are building master branch locally?

  2. 2 Posted by godrose on 16 Nov, 2018 05:03 PM

    godrose's Avatar

    Thanks for the reply. I’m building v2.0.0 locally.

  3. Support Staff 3 Posted by Owen McDonnell on 16 Nov, 2018 05:34 PM

    Owen McDonnell's Avatar

    What if you add these two lines to the first property group in your csproj?

    <GenerateAssemblyFileVersionAttribute>false</GenerateAssemblyFileVersionAttribute> 
    <GenerateAssemblyVersionAttribute>false</GenerateAssemblyVersionAttribute>
    
  4. 4 Posted by godrose on 17 Nov, 2018 04:36 PM

    godrose's Avatar

    It seems to work.
    Thanks

  5. Owen McDonnell closed this discussion on 18 Nov, 2018 04:43 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac