public git submodule fail

rack.kendorim's Avatar

rack.kendorim

29 Nov, 2018 08:13 PM

Hi, I have a problem with git submodules. The only way i have found it's to run script before build :
git submodule update --init --recursive
But This tips have worked the first time and now it doesn't works.
I have this log.

git : Submodule 'dependencies/googletest' (https://github.com/abseil/googletest.git) registered for path 'dependencies/googletest'
At line:1 char:1
+ git submodule update --init --recursive
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Submodule 'depe...ies/googletest':String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError


Cloning into 'C:/projects/synesthesia/dependencies/googletest'... Submodule path 'dependencies/googletest': checked out '191f9336bc9212b5f5410ab663176f685cafed2a' Command executed with exception: Cloning into 'C:/projects/synesthesia/dependencies/googletest'...
  1. Support Staff 1 Posted by Owen McDonnell on 30 Nov, 2018 12:35 AM

    Owen McDonnell's Avatar

    Can you try removing the ps: in front of that command, i.e. running it via cmd instead and let us know the outcome.

  2. 2 Posted by rack.kendorim on 30 Nov, 2018 02:07 PM

    rack.kendorim's Avatar

    Hi,
    It works with the cmd command.... but why powershell fail ? And why it works one time not other time

  3. Support Staff 3 Posted by Owen McDonnell on 30 Nov, 2018 06:33 PM

    Owen McDonnell's Avatar

    Please link to the build to which you are referring.

  4. 4 Posted by rack.kendorim on 03 Dec, 2018 04:33 PM

    rack.kendorim's Avatar

    Hi,
    my previous message is not passed
    the link : https://ci.appveyor.com/project/tmonseigne/synesthesia

  5. Support Staff 5 Posted by Owen McDonnell on 03 Dec, 2018 04:59 PM

    Owen McDonnell's Avatar

    I'm not sure i can say precisely why powershell fails except to say it seems to be interpreting feedback from this submodule update as errors.

    As to why it works one time and not the other, It looks like your initial build wasn't using an appveyor.yml config file at all. So perhaps you were not using powershell the first time that it worked.

  6. 6 Posted by rack.kendorim on 03 Dec, 2018 05:16 PM

    rack.kendorim's Avatar

    if so, I used it but I bypass the yml to test without powershell (to avoid 15 appveyor config commit). You're probably right for the fact that feedback becomes a mistake for him but in random mode or I was lucky the first time.

  7. Owen McDonnell closed this discussion on 27 Jun, 2019 05:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Aug, 2019 11:06 PM
21 Aug, 2019 02:08 PM
21 Aug, 2019 01:37 PM
21 Aug, 2019 10:21 AM
21 Aug, 2019 09:10 AM

 

21 Aug, 2019 05:56 AM
21 Aug, 2019 03:08 AM
20 Aug, 2019 11:33 PM
20 Aug, 2019 08:07 PM
20 Aug, 2019 05:50 PM
20 Aug, 2019 12:35 PM