Amazon S3 deployment says it's "OK" but nothing gets deployed

Matthew Taylor's Avatar

Matthew Taylor

09 Apr, 2015 10:34 PM

See https://ci.appveyor.com/project/numenta-ci/nupic-core/build/0.3.0.148

It says:

[00:15:58] Everything is Ok
[00:17:00] 
[00:17:00] 7-Zip [64] 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
[00:17:00] Scanning
[00:17:00] 
[00:17:00] Creating archive ..\..\nupic_core-0b9bd57b265767cfffbab628fe2d110de2d70306-Windows64.tar.gz
[00:17:00] 
[00:17:00] Compressing  nupic_core-0b9bd57b265767cfffbab628fe2d110de2d70306-Windows64.tar
[00:17:00] 
[00:17:00] Everything is Ok
[00:17:00] Packaging artifacts...
[00:17:04] OK
[00:17:04] Uploading artifact nupic_core-0b9bd57b265767cfffbab628fe2d110de2d70306-Windows64.tar.gz (24.1 MB)...
[00:17:15] OK
[00:17:16] Deploying using S3 provider
[00:17:16] Build success

Makes is seem like everything worked, doesn't it? But there is no file in S3!

  1. Support Staff 1 Posted by Feodor Fitsner on 09 Apr, 2015 11:08 PM

    Feodor Fitsner's Avatar

    What do you have in "Artifact" setting of S3 deployment provider?

    - Feodor

  2. 2 Posted by Matthew Taylor on 09 Apr, 2015 11:12 PM

    Matthew Taylor's Avatar

    You can see it here.

    after_build:
      - cd %REPO_DIR%\build\release
      - set PROJECT_BUILD_ARTIFACTS_DIR=%REPO_DIR%\build\artifacts
    

    And later:

    deploy:
      # Amazon S3 deployment provider settings
      - provider: S3
        access_key_id:
          secure: AKIAIGHYSEHV3WFKOWNQ
        secret_access_key:
          secure: qBtFVXdym4SmRUkpLSe7ISd2txresJXSdhQnlqFN/uOdzxrRTeL8FKUD1vgQDa1S9jhiyHXMVFiA65Q7JpSvNA==
        bucket: "artifacts.numenta.org"
        region: us-west-2
        set_public: true
        artifact: "%PROJECT_BUILD_ARTIFACTS_DIR%"
        folder: "numenta/nupic.core"
        on:
          branch: master```
    
  3. Support Staff 3 Posted by Feodor Fitsner on 09 Apr, 2015 11:16 PM

    Feodor Fitsner's Avatar

    "artifact" setting should contain exact artifact file name (as on Artifacts tab of build results) or artifact deployment name or regex matching either file or deployment name.

    - Feodor

  4. 4 Posted by Matthew Taylor on 09 Apr, 2015 11:19 PM

    Matthew Taylor's Avatar

    Thanks so much! I'm going to try this:

    artifact: "nupic_core-$env:APPVEYOR_REPO_COMMIT-Windows64.tar.gz"
    

    I'll let you know...

  5. Support Staff 5 Posted by Feodor Fitsner on 10 Apr, 2015 12:55 AM

    Feodor Fitsner's Avatar

    In order to expand environment variables it should be:

    artifact: "nupic_core-$(APPVEYOR_REPO_COMMIT)-Windows64.tar.gz"
    
  6. 6 Posted by Matthew Taylor on 10 Apr, 2015 04:06 PM

    Matthew Taylor's Avatar

    Ok, now I'm getting somewhere. Thanks for all your help.

    Everything is Ok
    Packaging artifacts...OK
    Uploading artifact nupic_core-9bb45a924d9d784ee55ce78fdd45599578cb8dc7-Windows64.tar.gz (24.2 MB)...OK
    Deploying using S3 provider
    Uploading artifact "nupic_core-9bb45a924d9d784ee55ce78fdd45599578cb8dc7-Windows64.tar.gz" (25,323,767 bytes) to S3 bucket "artifacts.numenta.org" as "numenta/nupic.core/nupic_core-9bb45a924d9d784ee55ce78fdd45599578cb8dc7-Windows64.tar.gz"
    Access Denied
    
  7. Support Staff 7 Posted by Feodor Fitsner on 10 Apr, 2015 05:26 PM

    Feodor Fitsner's Avatar

    Looks like access key used doesn't have enough permissions to upload to that bucket?

    - Feodor

  8. 8 Posted by Matthew Taylor on 10 Apr, 2015 05:34 PM

    Matthew Taylor's Avatar

    I just had the keys encrypted wrong. Everything is fixed and working now. Thanks for your help!

  9. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:55 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac