Deploy Is stuck (yellow) even if all the files has already been deployed

mark.garcia's Avatar

mark.garcia

22 Apr, 2015 12:50 PM

I've noticed this if I deploy on a live site with live traffic. It would deploy all the files but the indicator would not turn green. Any reason for this and best practice to avoid this. Deploying to a dormant site would only take a minute but the live one would take more than 20 mins and it would still not complete.

  1. Support Staff 1 Posted by Feodor Fitsner on 22 Apr, 2015 01:14 PM

    Feodor Fitsner's Avatar

    What deployment method do you use?

    - Feodor

  2. 2 Posted by mark.garcia on 23 Apr, 2015 02:14 AM

    mark.garcia's Avatar

    I'm using the appveyor agent

  3. Support Staff 3 Posted by Feodor Fitsner on 23 Apr, 2015 02:18 AM

    Feodor Fitsner's Avatar

    Can you please drop me a screenshot with deployment log?

  4. 4 Posted by mark.garcia on 23 Apr, 2015 03:08 AM

    mark.garcia's Avatar

    Deployment log file

  5. Support Staff 5 Posted by Feodor Fitsner on 23 Apr, 2015 03:20 AM

    Feodor Fitsner's Avatar

    Thanks for sending Deployment Agent log - should help int troubleshoot the issue.

    Could you please also send a screenshot of deployment log for that project on AppVeyor UI?

  6. Support Staff 6 Posted by Feodor Fitsner on 24 Apr, 2015 02:50 AM

    Feodor Fitsner's Avatar

    Hi Mark,

    Try updating to the latest pre-release Deployment Agent 2.6.0: http://www.appveyor.com/downloads/2.6.0/AppveyorDeploymentAgent.msi - we've added "hearbeat" functionality there to detect lost connections to AppVeyor.

    I also recalled that you are using the agent on Windows Server 2008 which connects via Server-Sent Events (SSE). It's definitely not the same as Web Sockets that are used on Windows Server 2012 and most probably SSE adds instability to connections. Deployment Agent still has "unsupported" status for Windows Server 2008 and current implementation works there in "experimental" mode. Though we do our best (and with your help of course) to extend the range of supported OSes with Windows Server 2008.

  7. 7 Posted by mark.garcia on 24 Apr, 2015 06:25 AM

    mark.garcia's Avatar

    Thank you, I'll try this tomorrow.

  8. Support Staff 8 Posted by Feodor Fitsner on 26 Apr, 2015 04:55 PM

    Feodor Fitsner's Avatar

    Mark,

    We deployed AppVeyor update with the latest SignalR 2.2 which fixes a bug related to working with groups and SSE. As a result Deployment Agent connectivity became much more stable even on Windows Server 2008!

    Update Deployment Agent to the latest:
    http://www.appveyor.com/docs/deployment/agent#installing-appveyor-d...

  9. 9 Posted by mark.garcia on 27 Apr, 2015 02:54 AM

    mark.garcia's Avatar

    I tried the new agent version and it's actually worse than the previous unofficial version, this one is deploying to a beta site and it's still not done.

  10. Support Staff 10 Posted by Feodor Fitsner on 27 Apr, 2015 02:55 AM

    Feodor Fitsner's Avatar

    That screenshot - click "Jobs" then "BUCH-WEBS2" job to see its progress/deployment log.

  11. 11 Posted by mark.garcia on 27 Apr, 2015 03:15 AM

    mark.garcia's Avatar

    It is stuck at downloading.

  12. 12 Posted by mark.garcia on 27 Apr, 2015 03:17 AM

    mark.garcia's Avatar

    I revert back to the previous agent and it finished after 2 mins.

  13. Support Staff 13 Posted by Feodor Fitsner on 27 Apr, 2015 03:21 AM

    Feodor Fitsner's Avatar
  14. 14 Posted by mark.garcia on 27 Apr, 2015 03:40 AM

    mark.garcia's Avatar

    v2.6, deployment either gets stuck or longer (the deploy took 13 mins) than the older "unofficial" version (which usually deploys our beta within 2 mins). I'm just testing v2.6 with our beta which usually deploys in 2 mins.

  15. 15 Posted by mark.garcia on 27 Apr, 2015 04:02 AM

    mark.garcia's Avatar

    the latest version looks stable now, I'll test more in a bit.

    Thanks

  16. 16 Posted by mark.garcia on 27 Apr, 2015 09:08 AM

    mark.garcia's Avatar

    This is a deploy to our live site and it took 20mins and it dropped. It deployed successfully though. I am using the v2.6 agent.

  17. Support Staff 17 Posted by Feodor Fitsner on 29 Apr, 2015 03:28 AM

    Feodor Fitsner's Avatar

    Mark,

    We've decided to remove "heartbeat" for now as it seems to work unreliable with Server-Side Events (communication protocol on Windows 2008 instead of Web Sockets).

    Please take 2.6.1 from here: http://www.appveyor.com/downloads/AppveyorDeploymentAgent.msi

  18. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:55 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Aug, 2019 11:06 PM
21 Aug, 2019 02:08 PM
21 Aug, 2019 01:37 PM
21 Aug, 2019 10:21 AM
21 Aug, 2019 09:10 AM

 

21 Aug, 2019 05:56 AM
21 Aug, 2019 03:08 AM
20 Aug, 2019 11:33 PM
20 Aug, 2019 08:07 PM
20 Aug, 2019 05:50 PM
20 Aug, 2019 12:35 PM