Python 3.7 stopped working

osbrain-ci's Avatar

osbrain-ci

26 Feb, 2019 11:58 AM

It seems Python 3.7 builds are failing (they never failed before):

https://ci.appveyor.com/project/osbrain-ci/osbrain/builds/22655380/job/g9vj011vb350p0x1

The other Python verions (3.5 and 3.6) are working as expected:

https://ci.appveyor.com/project/osbrain-ci/osbrain/builds/22655380

Source code:

https://github.com/opensistemas-hub/osbrain/pull/321

  1. Support Staff 1 Posted by Owen McDonnell on 27 Feb, 2019 01:04 AM

    Owen McDonnell's Avatar

    Python was updated in latest platform update. What version are you using locally to build successfully?

  2. 2 Posted by osbrain-ci on 27 Feb, 2019 08:52 AM

    osbrain-ci's Avatar

    I am using Python 3.7.2 locally, which I think is the latest Python 3.7 version.

  3. Support Staff 3 Posted by Owen McDonnell on 27 Feb, 2019 11:06 PM

    Owen McDonnell's Avatar

    I don't know too much about tox, but i installed latest python (3.7.2) on my local dev machine (windows) and tried to run your build script and ran into the same error as on the build VMs.
    Are there any other special steps i should take to make it build locally?

  4. 4 Posted by osbrain-ci on 27 Feb, 2019 11:59 PM

    osbrain-ci's Avatar

    Not reallly. Can you confirm you can run `tox -e py36` or `tox -e py35` but not `tox -e py37`?

    I am assuming you do have Python 3.7 available in your system, and that it is installed under C:\\Python37-x64, as it (should be?) installed in AppVeyor. At least that is what I have configured in the `.appveyor.yml` file, and used to work fine up until now..

  5. Support Staff 5 Posted by Owen McDonnell on 28 Feb, 2019 01:16 AM

    Owen McDonnell's Avatar

    Yes i can confirm that. I also rolled back to python 3.7.0 and your exact command worked (tox -e py -- -n 2 --color=yes).
    See attached screenshots.

  6. 6 Posted by osbrain-ci on 28 Feb, 2019 10:49 PM

    osbrain-ci's Avatar

    I opened this issue in Tox's repository:

    https://github.com/tox-dev/tox/issues/1178

    Apparently, it cannot be reproduced in Azure pipelines either.

    As I mention in that issue, I tried downgrading Tox (3.5.0) and virtualenv (16.1.0) and retriggered AppVeyor pipelines, but they failed again:

    https://ci.appveyor.com/project/osbrain-ci/osbrain/build/job/nt09n1vc64mcc2ov

    Do you think there is no way it could be an AppVeyor problem? Maybe not, but I am not sure who to report this issue at this point. :-/

  7. Support Staff 7 Posted by Owen McDonnell on 01 Mar, 2019 05:24 PM

    Owen McDonnell's Avatar

    I did some more testing locally and was able to make this command run if i skipped production of a virtualenv.
    Again, I don't have much experience with python development (especially tox testing) but it seems that tox creates its own virtualenv and so there is some confusion between which python.exe to use?

    Here is a build of your repo with the same approach which succeeds.

  8. 8 Posted by osbrain-ci on 04 Mar, 2019 09:05 AM

    osbrain-ci's Avatar

    Thanks Owen for having a look at it.

    Why do you think Tox would only get confused with Python 3.7 and not 3.5 or 3.6? Is it possible that AppVeyor's Python 3.7 is installed differently somehow? Or a path be missing somewhere?

    I ask because Tox is able to successfully run those pipelines with all Python versions in Azure Pipelines, Travis and locally, so it maybe is an AppVeyor-only problem.

  9. Support Staff 9 Posted by Owen McDonnell on 04 Mar, 2019 05:28 PM

    Owen McDonnell's Avatar

    Well as i demonstrated earlier, it's not an AppVeyor-only problem since it's on my local machine as well.
    Feel free to ask me any questions about my local machine, if you'd like to figure out the differences between it and your local machine.

    On travis, you're building on linux I assume?... not really comparable.

    What do you make of skipping virtualenv production leading to a successful build? Does tox not create its own virtualenv?

  10. 10 Posted by osbrain-ci on 04 Mar, 2019 05:48 PM

    osbrain-ci's Avatar

    Hi Owen,

    You are right, that works perfectly:

    https://ci.appveyor.com/project/osbrain-ci/osbrain/builds/22811070

    It seems I was missing `%PYTHON%\Scripts` in the `PATH`, which you had in your builds. I did not see that the first time I had a look at them.

    Thanks for your help and for your patience.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 Mar, 2019 06:34 AM
26 Mar, 2019 06:27 AM
25 Mar, 2019 09:12 PM
25 Mar, 2019 06:34 PM
25 Mar, 2019 06:20 AM

 

24 Mar, 2019 06:52 PM
24 Mar, 2019 05:26 PM
24 Mar, 2019 03:07 AM
22 Mar, 2019 02:20 PM
22 Mar, 2019 11:00 AM
22 Mar, 2019 02:51 AM