Missing environment variable VS140COMNTOOLS on VS 2015 RC

Gregor's Avatar

Gregor

06 May, 2015 09:37 PM

Hello,

according to my latest build, the variable VS140COMNTOOLS seems not to be set. Is this so by intention?

Gregor

  1. Support Staff 1 Posted by Feodor Fitsner on 07 May, 2015 01:38 AM

    Feodor Fitsner's Avatar

    Hi Gregor,

    Most probably it's not being set by Visual Studio 2015 installer then.

  2. 2 Posted by Gregor on 07 May, 2015 05:11 AM

    Gregor's Avatar

    Hi Feodor,

    on my development PC (Windows 8.1 Pro), the variable is set and pointing to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\. But maybe the variable was set by the installer of the CTP which I had installed previously.

    Gregor

  3. 3 Posted by Gregor on 07 May, 2015 07:43 PM

    Gregor's Avatar

    Mmh, I do not understand what I'm doing wrong: Visual Studio 2015 doesn't seem to be installed at all? In the project's settings, I have selected "Visual Studio 2015 RC".

    Gregor

  4. Support Staff 4 Posted by Feodor Fitsner on 07 May, 2015 07:46 PM

    Feodor Fitsner's Avatar

    If you are using appveyor.yml you should add there:

    os: Visual Studio 2015 RC
    
  5. 5 Posted by Gregor on 07 May, 2015 08:38 PM

    Gregor's Avatar

    Hi Feodor,

    thanks for the hint! And indeed, I've missed the following point in the documentation:

    It's worth noticing that both appveyor.yml and UI configuration are mutually exclusive.

    Gregor

  6. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:56 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac