Build failing even though it works locally

rymg19's Avatar

rymg19

06 May, 2015 10:50 PM

I'm trying to add AppVeyor support to fbuild, and it has not been fun. Basically, the script is crashing with an invalid handle error while trying to get the console attributes (more info here). However, this code worked when I tried it on my Windows 7 machine. Why would this be happening?

  1. Support Staff 1 Posted by Feodor Fitsner on 07 May, 2015 02:00 AM

    Feodor Fitsner's Avatar

    Could it be because AppVeyor runs "headless" builds (either Windows service or Windows Forms app) without console?

  2. 2 Posted by rymg19 on 07 May, 2015 02:04 AM

    rymg19's Avatar

    It does??? That would make sense...I should change the source to handle the case of no console.

  3. Support Staff 3 Posted by Feodor Fitsner on 07 May, 2015 02:27 AM

    Feodor Fitsner's Avatar

    Yes, for "interactive" builds Windows app was explicitly chosen to suppress console.

    - Feodor

  4. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:56 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Jan, 2019 12:17 AM
21 Jan, 2019 07:55 PM
21 Jan, 2019 05:55 PM
21 Jan, 2019 05:52 PM
21 Jan, 2019 03:59 PM