Production (Master Repo) Shows Incorrect Commit Data

John Carroll's Avatar

John Carroll

13 May, 2015 02:21 PM

Hi Feodor,

Everything was working fine until this afternoon, however, when we now push changes to our Develop branch, Appveyor also reports that these changes have been pushed to our Master branch. We can confirm that we have not pushed any changes to Master.

 This looks like a serious issue / defect...could you please advise?

Kind regards
John

  1. Support Staff 1 Posted by Feodor Fitsner on 13 May, 2015 02:28 PM

    Feodor Fitsner's Avatar

    Can you drop a screenshot of how that looks like?

    Also, what do you have in Recent deliveries for AppVeyor webhook on GitHub?

    - Feodor

  2. 2 Posted by John Carroll on 13 May, 2015 02:42 PM

    John Carroll's Avatar

    Hi Feodor, thanks for the quick response.

    Please find attached some screen shots that might help shed light on the
    issue.
    Also, we are using BitBucket for our source control.

    Regards
    John

  3. Support Staff 3 Posted by Feodor Fitsner on 13 May, 2015 02:49 PM

    Feodor Fitsner's Avatar

    Thanks. Well, I can't see builds of "master" on these screenshots. I'm still not sure I understand the issue.

    - Feodor

  4. 4 Posted by John Carroll on 13 May, 2015 02:56 PM

    John Carroll's Avatar

    Hi Feodor, I have also included a screenshot showing the settings for Prod
    which points to the Master branch. The earlier screenshot of the Projects
    page I sent you reports incorrectly, i.e. Master pointing to Develop!

    Regards
    John

  5. Support Staff 5 Posted by Feodor Fitsner on 13 May, 2015 03:02 PM

    Feodor Fitsner's Avatar

    Did you add appveyor.yml to repo recently?

    - Feodor

  6. 6 Posted by John Carroll on 13 May, 2015 03:30 PM

    John Carroll's Avatar

    No we haven't touched any yml files as far as I'm aware...just pushed
    standard C# source files etc...
    Everything was working fine this morning and the AppVeyor setting look ok
    (they haven't changed for months).
    For some strange reason (see images sent earlier) our AppVeyor Production
    environment thinks it is attached to our Develop branch instead of the
    Master branch as per the AppVeyor settings that haven't been touched.

    Kind regards
    John

  7. Support Staff 7 Posted by Feodor Fitsner on 13 May, 2015 03:40 PM

    Feodor Fitsner's Avatar

    OK, on a second look it seems AppVeyor is not authorized to access your BitBucket account anymore (most probably it was revoked on BB side). Open https://ci.appveyor.com/account and re-authorize BitBucket with correct account. You can also do that on New project page.

    - Feodor

  8. 8 Posted by John Carroll on 13 May, 2015 03:50 PM

    John Carroll's Avatar

    Hi Feodor, I haven't got the correct Admin privilege to do that it appears,
    I will get one of our Admin users to have a look.

    Please note that the message I see on the account page for BitBucket states:

    >
    > *BitBucket authorization*not authorized authorization form details
    > AppVeyor was authorized a month ago for *read/write* access to BitBucket
    > repositories as *vividcloud* <https://bitbucket.org/vividcloud> account.

    The guy who initally set this up (Anthony Seddon / VividCloud) is no longer
    with our company!
    Would it be possible to switch this to [email blocked] and
    also make Rowan an Administrator?

    Kind regards
    John

  9. 9 Posted by John Carroll on 13 May, 2015 03:55 PM

    John Carroll's Avatar

    Hi Feodor...please note that one of our existing Admin users (Jim
    Davenport) has revoked & re-authorized BitBucket access whilst also setting
    Rowan to be an Admin user.
    I'll check things out and see how things go...hopefully we'll be ok!

    Kind regards
    John

  10. Support Staff 10 Posted by Feodor Fitsner on 13 May, 2015 04:26 PM

    Feodor Fitsner's Avatar

    Yeah, let me know about the results.

  11. 11 Posted by John Carroll on 13 May, 2015 07:14 PM

    John Carroll's Avatar

    Thank you for your help Feodor :-)

    All looks good again and is back to normal.

    Kind regards
    John

  12. Support Staff 12 Posted by Feodor Fitsner on 13 May, 2015 07:15 PM

    Feodor Fitsner's Avatar

    Great, thanks for the update!

  13. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:56 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

20 Mar, 2019 11:39 PM
20 Mar, 2019 09:03 PM
20 Mar, 2019 08:55 PM
20 Mar, 2019 08:48 PM
20 Mar, 2019 08:02 PM

 

20 Mar, 2019 07:14 PM
20 Mar, 2019 06:27 PM
20 Mar, 2019 04:02 PM
20 Mar, 2019 08:51 AM
19 Mar, 2019 06:21 PM
19 Mar, 2019 05:22 PM