Switch-AzureWebsiteSlot

conor's Avatar

conor

15 May, 2015 01:51 PM

When I run the Azure Powershell command 'Switch-AzureWebsiteSlot ' I get the error "The method or operation is not implemented".

The command runs fine on my local Win8.1 machine. I've tried using your "Default Azure" and "Windows Server 2012 R2" environments - both give the error.

My overall aim is to deploy to the staging slot on Azure and then swap them over after deployment.

Have you any ideas why I can't use this command?

  1. Support Staff 1 Posted by Feodor Fitsner on 15 May, 2015 05:07 PM

    Feodor Fitsner's Avatar

    Have you tried calling import-module Azure before that cmdlet?

  2. 2 Posted by conor on 17 May, 2015 06:20 PM

    conor's Avatar

    I have and it doesn't seem to resolve the issue.

  3. Support Staff 3 Posted by Feodor Fitsner on 18 May, 2015 04:01 AM

    Feodor Fitsner's Avatar

    OK, I've got it.

    The cmdlet itself is not a problem at all. It exists on Pro environment images and you don't need to specify os. I tested it here: https://ci.appveyor.com/project/FeodorFitsner/simple-console/build/...

    Then that The method or operation is not implemented error comes from AppVeyor custom PowerShell host and it means cmdlet is asking for some input which obviously not supported/implemented. Most probably there are some parameters missing while calling that cmdlet.

  4. 4 Posted by conor on 18 May, 2015 12:03 PM

    conor's Avatar

    Right. Would it be possible to have the errors passed through so we can see what's going on. As you can see, I went through about 70 builds trying to debug that :)

    I have no idea why the command works for me and not there which also makes it difficult for me to debug.

    Is it possible to connect to your servers and run powershell commands directly?

  5. Support Staff 5 Posted by Feodor Fitsner on 18 May, 2015 05:19 PM

    Feodor Fitsner's Avatar
  6. 6 Posted by conor on 19 May, 2015 08:40 AM

    conor's Avatar

    Thanks. That's very useful.

    I *think* the issue may have been due to running commands that require confirmation. Adding a -Force flag got the build through.

  7. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:56 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac