Builds fail, missing libc?

Paril's Avatar


09 Mar, 2019 02:34 AM

My builds have been failing, with libc files missing. I have the toolkit set to v141_clang_c2 and the sdk version set to 10.0.17134.0 - the builds succeed on my local VS2017 installations.

Any idea what might be causing it to not be able to find libc?

  1. Support Staff 1 Posted by Owen McDonnell on 11 Mar, 2019 04:09 PM

    Owen McDonnell's Avatar

    Ans what if your hit RE-BUILD COMMIT on this build.

  2. 2 Posted by Paril on 11 Mar, 2019 07:27 PM

    Paril's Avatar

    Hmm. That's bizarre, that build works. I haven't updated the builds in a
    long time, I just came back after a while to get the AppVeyor builds
    working again. I haven't changed anything configuration-wise that would
    cause this.
    The only thing I changed was setting the Windows SDK version
    to 10.0.17134.0 - is that version missing from AppVeyor maybe?

  3. Support Staff 3 Posted by Owen McDonnell on 11 Mar, 2019 09:21 PM

    Owen McDonnell's Avatar

    You are building on default image which is Visual Studio 2015, can you try switching to visual studio 2017 image.

  4. 4 Posted by Paril on 12 Mar, 2019 08:51 AM

    Paril's Avatar

    I have it set to Visual Studio 2017 in the options though, is that not being used?

  5. Support Staff 5 Posted by Owen McDonnell on 12 Mar, 2019 02:40 PM

    Owen McDonnell's Avatar

    Not when you have an appveyor.yml in your repo. You can read about how settings from both work together here.

  6. 6 Posted by Paril on 12 Mar, 2019 02:47 PM

    Paril's Avatar

    Oh interesting. I wasn't aware some were ignored, I thought it was like
    inherited. Thanks! I'll fix it up when I get home.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac