Missing powershell module on linux

zeppaman's Avatar

zeppaman

12 Mar, 2019 06:34 PM

Hello,
After some issues I used this solution to set environement variables on build:
https://help.appveyor.com/discussions/problems/6816-having-problem-...

The solution works, but path is windows specific (import-module 'C:\Program Files\AppVeyor\BuildAgent\Modules\build-worker-api')

The module can be used in linux images? It is in some path or can be downloaded during build?

  1. Support Staff 1 Posted by Ilya Finkelshte... on 13 Mar, 2019 11:38 PM

    Ilya Finkelshteyn's Avatar

    All build worker API commands and PowerShell commandlets work on Linux out of the box. This specific command (Set-AppveyorBuildVariable) works a little bit different on Linux: variable is not being available until next build step, e.g. you need to add something like $env:var="val"` if you need to call variable from within the same step.

    If this does not help, please provide detailed description and a way to reproduce the problem.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

20 Mar, 2019 01:15 PM
20 Mar, 2019 11:09 AM
20 Mar, 2019 10:37 AM
20 Mar, 2019 09:01 AM
20 Mar, 2019 08:51 AM

 

20 Mar, 2019 02:33 AM
19 Mar, 2019 06:21 PM
19 Mar, 2019 06:03 PM
19 Mar, 2019 05:22 PM
19 Mar, 2019 05:08 PM
19 Mar, 2019 05:00 PM