.net standard

Mauro Sampietro's Avatar

Mauro Sampietro

19 Mar, 2019 01:31 PM

hello,

I have a solution containing a .Net Framework project and a .Net Standard project.

I'm having several problems building the .Net Standard project.
I tried to "nuget restore" with no luck.
The following is my appveyor.yml.
What should i do?
Thanks

version: 0.2.{build}
pull_requests:
  do_not_increment_build_number: true
image: Visual Studio 2017
assembly_info:
  patch: true
  file: '**\AssemblyInfo.*'
  assembly_version: '{version}'
  assembly_file_version: '{version}'
  assembly_informational_version: '{version}'
before_build:
- cmd: nuget restore
build:
  publish_nuget: true
  verbosity: minimal
deploy:
- provider: NuGet
  api_key:
    secure: u+KuVfwNaVSx3MHSnyjvIAn25rTxUF9HxQs6F7VOG1OlLYtDT7+19f4zskbiXCP2
  skip_symbols: true
- provider: GitHub
  tag: UltraMapper v$(appveyor_build_version)
  release: UltraMapper v$(appveyor_build_version)
  auth_token:
    secure: xdVPCgGLq4ImYFV39Kc4CSd2+bR+HtfN1Iu+NFMYirkeYz4rCboJV+uxiraKjzsO1E7UZelFAmHNXoKRA9IAFEpErerm+/nTjVMtD8AWMyE=
  artifact: /.*\.nupkg/
© 2019 GitHub, Inc.

  1. 1 Posted by Mauro Sampietro on 19 Mar, 2019 01:36 PM

    Mauro Sampietro's Avatar

    A just tried a rebuild and i get the following error now:

    "Error publishing package. NuGet server returned 403: The specified API key is invalid, has expired, or does not have permission to access the specified package."

  2. Support Staff 2 Posted by Owen McDonnell on 19 Mar, 2019 03:09 PM

    Owen McDonnell's Avatar

    So the problem running the nuget restore command is no longer an issue?

  3. 3 Posted by Mauro Sampietro on 19 Mar, 2019 03:59 PM

    Mauro Sampietro's Avatar

    I guess it is no more an issue, but I did nothing I just launched a new build.

    The problem outlined in the comment still exists

    Mauro Sampietro

  4. Support Staff 4 Posted by Owen McDonnell on 19 Mar, 2019 05:08 PM

    Owen McDonnell's Avatar

    Can you point me to the build where nuget restore failed.

  5. 5 Posted by mauro on 20 Mar, 2019 03:43 PM

    mauro's Avatar
  6. Support Staff 6 Posted by Owen McDonnell on 20 Mar, 2019 04:02 PM

    Owen McDonnell's Avatar

    I still don't see where nuget restore command caused any error.

    Regardless, I don't see anything wrong with your nuget deployment settings so it's probably worthwhile regenerating and re-encrypting your api key.

  7. Ilya Finkelshteyn closed this discussion on 20 May, 2019 09:01 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac