Refreshed badge URI - stuck on failing?

MSP-Greg's Avatar

MSP-Greg

20 Apr, 2019 01:00 PM

See badge at:
https://github.com/puma/puma

See https://ci.appveyor.com/project/puma/puma/history, which as of writing this, is passing.

JFYI, a long time ago, the repo usedd a personal account for Appveyor CI, and was then changed to a 'organization' account. The URI in the READ wasn't changed to reflect that. I have used a badge in a repo of mine, and never noticed any issues...

  1. 1 Posted by MSP-Greg on 20 Apr, 2019 02:00 PM

    MSP-Greg's Avatar
  2. Support Staff 2 Posted by Owen McDonnell on 22 Apr, 2019 01:48 PM

    Owen McDonnell's Avatar

    Have you tried something more closely resembling our docs.
    Something like

    https://ci.appveyor.com/api/projects/status/f3fnx29ybmq9by9x/branch/master?svg=true
    
  3. 3 Posted by MSP-Greg on 22 Apr, 2019 02:06 PM

    MSP-Greg's Avatar

    Owen,

    Thanks for the response. The format you show is the format used in the Puma README.md file, which is also showing failing

    https://ci.appveyor.com/api/projects/status/f3fnx29ybmq9by9x?branch=master&svg=true
    

    See

    https://raw.githubusercontent.com/puma/puma/master/README.md

  4. 4 Posted by MSP-Greg on 22 Apr, 2019 02:11 PM

    MSP-Greg's Avatar

    Owen,

    I just noticed the distinction between using /branch/master in the URI vs using the branch= parameter. Regardless, all badge versions show a failed build,

    See

    https://ci.appveyor.com/project/puma/puma/history

  5. 5 Posted by MSP-Greg on 22 Apr, 2019 03:04 PM

    MSP-Greg's Avatar

    Owen,

    I forgot to just show the URI you suggested...

  6. Support Staff 6 Posted by Owen McDonnell on 22 Apr, 2019 03:46 PM

    Owen McDonnell's Avatar

    Can you take a screenshot of your project Settings -> Badges page.

  7. 7 Posted by MSP-Greg on 22 Apr, 2019 04:09 PM

    MSP-Greg's Avatar

    I'll ask, I'm a contributor, but not a member, so I don't have access.

    Any idea why the 'public' badge isn't working?

    For a repo of mine, both the 'public' and 'private' badges have always worked...

  8. Support Staff 8 Posted by Owen McDonnell on 22 Apr, 2019 04:41 PM

    Owen McDonnell's Avatar

    Probably because there is another project for that repository within AppVeyor.

  9. 9 Posted by MSP-Greg on 22 Apr, 2019 04:52 PM

    MSP-Greg's Avatar

    I guess if AV can resolve:
    https://ci.appveyor.com/project/puma/puma
    I'm not quite sure why the same info doesn't resolve the badge.

    I'll ask someone to check the 'private' badge URI...

  10. 10 Posted by MSP-Greg on 23 Apr, 2019 03:12 PM

    MSP-Greg's Avatar

    Owen,

    Not sure how, what & where, but a member of the repo checked, we updated the 'private' URI, and the badge is working. OK to close. Thanks, Greg

  11. Support Staff 11 Posted by Owen McDonnell on 23 Apr, 2019 04:10 PM

    Owen McDonnell's Avatar

    Cool. Thanks for letting us know.

  12. Owen McDonnell closed this discussion on 23 Apr, 2019 04:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac