[SOLVED] vcpkg install icu:x64-windows appears to make the Visual Studio 2017 image freeze and the build stops

white.tw.tw's Avatar

white.tw.tw

10 May, 2019 07:54 PM

Not sure what's going on. Only that a build I have been trying to setup appears to freeze and timeout once "vcpkg install icu:x64-windows" has completed.

So a simple build such as :

ECHO Building...

C:

CD C:\Tools\vcpkg

vcpkg install icu:x64-windows

ECHO Complete

Will fail to send the ECHO Complete to the log as it will not complete. The build will just hang and timeout.
Please see this build https://ci.appveyor.com/project/TonyW/bhawk/builds/24460709
Thanks.

  1. Support Staff 1 Posted by Owen McDonnell on 10 May, 2019 08:27 PM

    Owen McDonnell's Avatar

    Can you please try to RDP to build worker and see if there is some GUI window blocking build progress.

  2. 2 Posted by white.tw.tw on 11 May, 2019 03:51 PM

    white.tw.tw's Avatar

    Hi Owen.
    Thank You for the swift reply and the excellent suggestion. Your query confirmed one of the two possibilities I had reasoned it could be:

    • VM corruption or processing error
    • Stale process left over from vcpkg

    I was able to confirm that the issue was with vcpkg. I stumbled upon a bug report here:
    https://github.com/microsoft/vcpkg/issues/5476
    And have submitted a patch to vcpkg:
    https://github.com/microsoft/vcpkg/pull/6407

    I reasoned that as the gpg-agent.exe process wasn't blocking the build locally, but was still running well after the build had finished, that it was the cause of the issue.

    Thanks for your help. This one is solved!

  3. Support Staff 3 Posted by Owen McDonnell on 13 May, 2019 04:00 AM

    Owen McDonnell's Avatar

    Great, thanks for the detailed explanation!

  4. Owen McDonnell closed this discussion on 13 May, 2019 04:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac