node error failing build

Aqil's Avatar

Aqil

26 Jun, 2015 11:00 AM

Hi

Since morning all builds have started failing and error logs shows following:

Install-Product node 2.2.1
Uninstalling node 0.10.38 (x86)...
Installing node 2.2.1 (x86)...
npm -g install npm@2
C:\Users\appveyor\AppData\Roaming\npm\npm -> C:\Users\appveyor\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js
npm@2.12.0 C:\Users\appveyor\AppData\Roaming\npm\node_modules\npm
set PATH=%APPDATA%\npm;%PATH%
npm install --production
npm WARN package.json @0.0.0 No README data
npm WARN package.json @0.0.0 No license field.
npm ERR! Windows_NT 6.3.9600
npm ERR! argv "C:\\Program Files (x86)\\iojs\\node.exe" "C:\\Users\\appveyor\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install" "--production"
npm ERR! node v2.2.1
npm ERR! npm v2.12.0
 
npm ERR! process.getuid is not a function
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! <https://github.com/npm/npm/issues>
 
npm ERR! Please include the following file with any support request:
npm ERR! C:\projects\mediaappsln-clf3w\AdazzleMediaAppWebCS\npm-debug.log
Command exited with code 1

any idea what is going wrong ?

  1. 1 Posted by giacomo.tag on 26 Jun, 2015 11:52 AM

    giacomo.tag's Avatar

    Same for me. I am googling it right now to understand what could be going wrong in the appveyor environment

  2. Support Staff 2 Posted by Feodor Fitsner on 26 Jun, 2015 02:01 PM

    Feodor Fitsner's Avatar

    Nothing has been changed in AppVeyor environment overnight. Last update was on June 20: http://www.appveyor.com/updates

    Thought seems like it fails on installing npm 2.12.0. You are pulling the latest version - maybe something changed there?

    - Feodor

  3. 3 Posted by Aqil on 26 Jun, 2015 02:05 PM

    Aqil's Avatar

    That's right. It is due to some change in npm versions released recently
    https://github.com/npm/npm/tags
    Tried different version and got same error with v2.12.0, v2.12.1 and v3.0.0
    Last npm version which works without any problem is v2.11.3
    Now I explicitly install v2.11.3 instead of getting latest version and it works fine.
    npm -g install npm@2.11.3

  4. 4 Posted by giacomo.tag on 26 Jun, 2015 02:08 PM

    giacomo.tag's Avatar

    Thanks for sharing the finding. Regarding npm, do you know what could cause this "process.getuid not a function" error?

  5. Support Staff 5 Posted by Feodor Fitsner on 26 Jun, 2015 02:32 PM

    Feodor Fitsner's Avatar

    Interesting, according to this page npm 2.12.0 was released 7 days ago, but this build ran 4 days ago was pulling 2.11.3: https://ci.appveyor.com/project/FeodorFitsner/av-build-problem/buil...

    Now, when it pull 2.12.0 it breaks with a similar error: https://ci.appveyor.com/project/FeodorFitsner/av-build-problem/buil...

    I'm going to file an issue there.

  6. Support Staff 6 Posted by Feodor Fitsner on 26 Jun, 2015 02:52 PM

    Feodor Fitsner's Avatar

    Can you check in your build logs please if npm 2.12.0 started to be downloaded just today?

  7. Support Staff 7 Posted by Feodor Fitsner on 26 Jun, 2015 02:54 PM

    Feodor Fitsner's Avatar

    I've filed a new issue: https://github.com/npm/npm/issues/8702

    Could you please review it and comment/improve?

  8. 8 Posted by Aqil on 26 Jun, 2015 03:15 PM

    Aqil's Avatar

    Feodor - checked build logs. Yes until yesterday 2.11.3 was being downloaded but around 7 hours ago from now 2.12.0 started downloading as a result of
    npm -g install npm@2 and builds started failing.

  9. 9 Posted by Aqil on 26 Jun, 2015 03:16 PM

    Aqil's Avatar

    Thanks for filing issue.

  10. Support Staff 10 Posted by Feodor Fitsner on 26 Jun, 2015 03:16 PM

    Feodor Fitsner's Avatar

    Yeah, let's hang there :)

  11. Support Staff 11 Posted by Feodor Fitsner on 26 Jun, 2015 04:35 PM

    Feodor Fitsner's Avatar
  12. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac