NuGet package restored but issue persists

Giacomo Stelluti Scala's Avatar

Giacomo Stelluti Scala

29 Jun, 2015 12:25 PM

Dear Support Team,
I've recently added my open source project to AppVeyor: https://ci.appveyor.com/project/gsscoder/commandline.

From settings you can see that I (correctly?) restore NuGet packages, but build fails anyway.

In what am I wrong?

Regards,
Giacomo

  1. Support Staff 1 Posted by Feodor Fitsner on 29 Jun, 2015 03:20 PM

    Feodor Fitsner's Avatar

    Seems like your repo doesn't contain .nuget folder?

  2. 2 Posted by Giacomo Stellut... on 30 Jun, 2015 03:23 PM

    Giacomo Stelluti Scala's Avatar

    Thanks for replying, Feodor!

    Yes, it was an oversight :( ... Now I've added it as empty dir, is this correct right?

    Anyway build fail.

    Regards, Giacomo

  3. Support Staff 3 Posted by Feodor Fitsner on 30 Jun, 2015 04:14 PM

    Feodor Fitsner's Avatar

    There is still no nuget.targets in that folder: https://github.com/gsscoder/commandline/tree/master/.nuget

  4. 4 Posted by Giacomo Stellut... on 01 Jul, 2015 05:11 PM

    Giacomo Stelluti Scala's Avatar

    **SUCCESS!**

    Thanks again Feodor,
    I added `nuget.targets` and still not worked. To solve it seems that **AppVeyor** needs also binaries inside. To be precise it requires `.nuget` in repo root complete with binary images.

    First time, I thought that an empty folder would have been sufficient. (Or least a `.nuget` folder with just the file you quoted...)

    But... this is not a problem to me!

    And actually I found great that AppVeyor allow open source project to be hosted free.

    Thanks again,
    Giacomo

  5. Support Staff 5 Posted by Feodor Fitsner on 01 Jul, 2015 05:14 PM

    Feodor Fitsner's Avatar

    Cool, thanks for the update!

    - Feodor

  6. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Mar, 2019 01:47 AM
20 Mar, 2019 11:39 PM
20 Mar, 2019 09:03 PM
20 Mar, 2019 08:55 PM
20 Mar, 2019 08:48 PM

 

20 Mar, 2019 08:02 PM
20 Mar, 2019 07:14 PM
20 Mar, 2019 06:27 PM
20 Mar, 2019 04:02 PM
19 Mar, 2019 06:21 PM
19 Mar, 2019 05:22 PM