Network error on worker image Visual Studio 2019

uilianries's Avatar

uilianries

03 Jun, 2019 02:10 PM

Hi!

First, thanks for including Visual Studio 2019 in your worker images, it helps a lot.

I'm using Appveyor worker images "Visual Studio 2015", "Visual Studio 2017" and "Visual Studio 2016" to build a bunch of projects. So far so good, I can build those project using 2015 and 2017, but for 2019 I've noticed some builds are failing due networking error.

Our process is:
1) Download dependencies (C/C++)
2) Build project (C/C++)
3) Authenticate to a specific remote server (JFrog Bintray)
4) Upload all artifacts (JFrog Bintray)

The step 2 works well for any worker images, however the steps 1 and 3 ONLY fail for the newest image: Visual Studio 2019. We are using the same remote for all Worker images, so I can't believe is an error from the server, it sounds more like an instability with the new worker image.

Some logs that are related:
https://ci.appveyor.com/project/ConanCIintegration/conan-openssl/bu...
https://ci.appveyor.com/project/ConanCIintegration/conan-openssl/bu...
https://ci.appveyor.com/project/ConanCIintegration/conan-openssl/bu...
https://ci.appveyor.com/project/ConanCIintegration/conan-boost/buil...

You can verify that the same build worked for Visual Studio 2015 and 2017, only 2019 is falling.

  1. 1 Posted by Ilya Finkelshte... on 03 Jun, 2019 08:48 PM

    Ilya Finkelshteyn's Avatar

    Hi Uilian,

    Are there any IP restrictions on the remote server ti connect to https://api.bintray.com/conan/conan-community/conan? If yes, please check that all our IPs are included: https://www.appveyor.com/docs/build-environment/#ip-addresses

    Specifically Visual Studio 2019 image is running on Azure West US now, IP 138.91.141.243.

    Ilya.

  2. 2 Posted by uilianries on 05 Jun, 2019 12:06 PM

    uilianries's Avatar

    Hi Ilya!

    We have investigated with Bintray team, and there is no IP block/filter on
    their side.

    Is there a specific configuration for Visual Studio 2019, like SSL?

  3. 3 Posted by Ilya Finkelshte... on 05 Jun, 2019 05:55 PM

    Ilya Finkelshteyn's Avatar

    Please check this simple experiment I did with both connecting to that URL and uploading to the BinTray repository I created. As you see all works OK.

    However I created just a "Generic" repository, not a "Conan" one as I am not familiar with it and assume that networking issues are not related to the directory type. Can you help with creating this kind of "hello world" repro with "Conan" repo type?

  4. 4 Posted by uilianries on 13 Jun, 2019 02:05 PM

    uilianries's Avatar

    Hi again!

    Using alternative environments I could reproduce the same error, so I can confirm it is not a problem related to Appveyor. When I say "alternative environments", I mean, other PCs running Windows 10 + MSVC 16 2019.

    Sorry about this and thanks for supporting me!

  5. 5 Posted by Ilya Finkelshte... on 13 Jun, 2019 04:39 PM

    Ilya Finkelshteyn's Avatar

    Oh, no worries at all, thanks for coming back :)

  6. Ilya Finkelshteyn closed this discussion on 13 Jun, 2019 04:39 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac