GitHub WebHook problem

Alvaro's Avatar

Alvaro

30 Jun, 2015 01:43 PM

Hi,

I am currently getting this error:

Response status code does not indicate success: 404 (Not Found).

I have been using successfully AppVeyor the last few days, but since this morning with no change on the configuration I started having problems with the hooks to GitHub.

I removed the and recreated them again (with Push and PullRequest permisions as previous ones where done). But not success for now. I am not even able to force the build from appVeyor Web UI, for me it looks like the link in between my GitHub repository and AppVeyor is broken.

Any Ideas?

my builds are:
- CI - Release

  1. Support Staff 1 Posted by Feodor Fitsner on 30 Jun, 2015 02:10 PM

    Feodor Fitsner's Avatar

    Go to https://ci.appveyor.com/account and reauthorize GitHub.

    - Feodor

  2. 2 Posted by Alvaro on 30 Jun, 2015 07:09 PM

    Alvaro's Avatar

    Thanks for the fast reply. It didnt work after simply reauthorize. So i revoked in github. and plan to do same steps again. But end up hitting a bug in the web UI. I cannot access anymore GitHub Authorization options.

  3. Support Staff 3 Posted by Feodor Fitsner on 30 Jun, 2015 07:10 PM

    Feodor Fitsner's Avatar

    I've reset it from here. You can re-authorize now.

  4. 4 Posted by Alvaro on 30 Jun, 2015 07:34 PM

    Alvaro's Avatar

    Thank you very much Feodor.

     Sorry if I haven't answer straight after, but i was doing some testing I can confirm that I still have a 404(not found).
    So I have removed the webhooks and re add them but the problem was still there, the workaround that has worked for me is recreate the entire build specification. Dont know if this can help you understand the case, but any other info you need or want let me know.

  5. Support Staff 5 Posted by Feodor Fitsner on 30 Jun, 2015 07:38 PM

    Feodor Fitsner's Avatar

    Make sure GitHub account you are authorizing in AppVeyor has access to project repositories.

  6. 6 Posted by Alvaro on 30 Jun, 2015 08:14 PM

    Alvaro's Avatar

    yes they are my own ones, so I have full privilege over them.
    New builds Same parameters: work
    Old builds Same parameters: fail
    must be something related to webhooks

  7. Support Staff 7 Posted by Feodor Fitsner on 30 Jun, 2015 08:23 PM

    Feodor Fitsner's Avatar

    What do you mean by "new builds"?

    - Feodor

  8. Support Staff 8 Posted by Feodor Fitsner on 30 Jun, 2015 08:37 PM

    Feodor Fitsner's Avatar

    Oh wait, I see. You created two new projects for the same repos and they worked when clicking "New build" button while old projects didn't, correct?

    - Feodor

  9. 9 Posted by Alvaro on 30 Jun, 2015 08:40 PM

    Alvaro's Avatar

    yes correct, and the only real difference are the webhooks.

  10. Support Staff 10 Posted by Feodor Fitsner on 30 Jun, 2015 08:43 PM

    Feodor Fitsner's Avatar

    Maybe the problem is that old projects have "Default branches" configured that don't exist any more, so AV can't read the latest commit?

    - Feodor

  11. 11 Posted by Alvaro on 30 Jun, 2015 08:56 PM

    Alvaro's Avatar

    Both branches still exist. Just for the sake of testing I made the default branches match in one of the old definitions with the new one, but didn't remove the 404 error.
    About the branches, there was a change at the point old definitions stopped working, but was not a deleted branch, was the add of a new branch (automatically by github) gh-pages.

  12. Support Staff 12 Posted by Feodor Fitsner on 30 Jun, 2015 09:01 PM

    Feodor Fitsner's Avatar

    Can you add my email "feodor AT appveyor.com" to collaborators (https://ci.appveyor.com/team) please so I can look at the issue?

    - Feodor

  13. 13 Posted by Alvaro on 30 Jun, 2015 09:46 PM

    Alvaro's Avatar

    you should have access now :). Here is almost midnight so I will disconnect for now. Anything else you need let me know.

  14. Support Staff 14 Posted by Feodor Fitsner on 30 Jun, 2015 09:51 PM

    Feodor Fitsner's Avatar

    OK, thanks.

    - Feodor

  15. Support Staff 15 Posted by Feodor Fitsner on 01 Jul, 2015 12:21 AM

    Feodor Fitsner's Avatar

    OK, found it. The repo was renamed from Hatisoft/ErrorListSearchOn to Hatisoft/SearchErrorOn, so old projects can't read it anymore. Update repo path in project settings to make them work again.

    Btw, I moved your account to a new environment with VS 2015 RC, so don't set custom OS to take advantage of a new environment.

  16. 16 Posted by Alvaro on 01 Jul, 2015 04:49 AM

    Alvaro's Avatar

    sorry... didn't noticed that at all O_O..., is a stupid mistake from my side...really thank you for helping me out.
    Also thanks for moving it to the new environment :).

  17. 17 Posted by jake on 01 Jul, 2015 01:56 PM

    jake's Avatar

    I seem to be having the same issue for https://ci.appveyor.com/project/shouldly/shouldly and the repo is https://github.com/shouldly/shouldly
    The repo was not renamed.

    I have added you as a collaborator Feodor.

  18. Support Staff 18 Posted by Feodor Fitsner on 01 Jul, 2015 03:23 PM

    Feodor Fitsner's Avatar

    You can re-authorize now. Btw, I've moved your account to a new environment.

  19. 19 Posted by jake on 02 Jul, 2015 12:47 AM

    jake's Avatar

    Thanks Feodor. Just noticed https://ci.appveyor.com/project/TestStack/teststack-conventiontests has the same issue. Just checked all my other builds too, they are fine.

  20. Support Staff 20 Posted by Feodor Fitsner on 02 Jul, 2015 04:33 AM

    Feodor Fitsner's Avatar

    Re: TestStack account - you mean there is 404 preventing you from re-authorize?

  21. 21 Posted by jake on 02 Jul, 2015 04:40 AM

    jake's Avatar

    Yep exactly. And if I try to queue a build it says unauthorized.

  22. Support Staff 22 Posted by Feodor Fitsner on 02 Jul, 2015 04:46 AM

    Feodor Fitsner's Avatar

    OK, I've reset authorization. You can re-authorize now.

  23. 23 Posted by jake on 02 Jul, 2015 04:59 AM

    jake's Avatar

    Cheers, all sorted now ☺

    Might be worth exposing the Revoke GitHub access button when there is an error to reset it when this happens? Then I can sort it myself. Though not sure why it happened.

  24. Support Staff 24 Posted by Feodor Fitsner on 02 Jul, 2015 05:03 AM

    Feodor Fitsner's Avatar
  25. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 Mar, 2019 06:34 AM
26 Mar, 2019 06:27 AM
25 Mar, 2019 09:12 PM
25 Mar, 2019 06:34 PM
25 Mar, 2019 06:20 AM

 

24 Mar, 2019 06:52 PM
24 Mar, 2019 05:26 PM
24 Mar, 2019 03:07 AM
22 Mar, 2019 02:20 PM
22 Mar, 2019 11:00 AM
22 Mar, 2019 02:51 AM