** URGENT ** Dev Release Deployment Not Working

John Carroll's Avatar

John Carroll

30 Jun, 2015 03:51 PM

Hi Feodor,

I am trying to deploy to our Dev environment in Azure and for some reason this has stopped working this afternoon.
The script seems to have froze on the line "Uploading package..."

Everything worked ok yesterday...just wondering if there is an internal issue on your side?

Kind regards
John

  1. Support Staff 1 Posted by Feodor Fitsner on 30 Jun, 2015 03:57 PM

    Feodor Fitsner's Avatar

    Hi John,

    Nothing has been changed on our side recently. Have you tried redeploying to see if the problem is intermittent?

    - Feodor

  2. 2 Posted by John Carroll on 30 Jun, 2015 04:05 PM

    John Carroll's Avatar

    Hi Feodor, yeah...same problem each time.

    It just seems to hang with the following message:
    "Uploading package "LivSmarter.Services.cspkg" to Azure Blob storage "devlivsmarter" as "packages/touch4-livsmarter/1.0.756/LivSmarter.Services.cspkg"..."

    Could this be an Azure issue?
    Everything has been fine for the last few weeks.

    Kind regards
    John

  3. Support Staff 3 Posted by Feodor Fitsner on 30 Jun, 2015 04:13 PM

    Feodor Fitsner's Avatar

    Maybe. What Azure region is it uploading into?

  4. 4 Posted by John Carroll on 30 Jun, 2015 04:16 PM

    John Carroll's Avatar

    Hi,

    All our Worker Role services are located in Western Europe.

    Kind regards
    John

  5. Support Staff 5 Posted by Feodor Fitsner on 30 Jun, 2015 04:30 PM

    Feodor Fitsner's Avatar

    AppVeyor is in West US. Maybe it's not hanging but just very slow between these regions.

    Try creating Azure storage in a different region and us it for uploading CS package/config.

  6. Support Staff 6 Posted by Feodor Fitsner on 30 Jun, 2015 04:54 PM

    Feodor Fitsner's Avatar

    Yeah, I've created a new storage in West Europe region and indeed it hangs while trying to upload package there.

    With test cloud service located in West Europe region I created a new storage in East US and used it for deployment - that worked (though it might be not effective from bandwidth perspective).

    Btw, something network-related is happening on Azure right now: http://azure.microsoft.com/en-us/status/#current

  7. 7 Posted by John Carroll on 30 Jun, 2015 09:09 PM

    John Carroll's Avatar

    Thank you Feodor, this has worked great for months so I knew something wacky was going on somewhere!

    I've left it for a few hours and will try again now...certainly looks Azure related :-)

    Kind regards
    John

  8. 8 Posted by John Carroll on 30 Jun, 2015 09:20 PM

    John Carroll's Avatar

    I can confirm all is working well again...phew!

    Kind regards
    John

  9. Support Staff 9 Posted by Feodor Fitsner on 30 Jun, 2015 09:26 PM

    Feodor Fitsner's Avatar

    Great, thanks for update!

    - Feodor

  10. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac