JS errors

stage.innovadis's Avatar

stage.innovadis

01 Jul, 2015 01:16 PM

While adding new projects with Visual Studio Online, I received an error.

Error adding webhook to VSO repository: Forbidden
It also comes with Javascript errors:
POST https://ci.appveyor.com/api/projects 500 (Internal Server Error)

I tried revoking privileges and restarting, but this didnt help.
Does this mean there are in fact server problems or is it something I've done wrong?

Thanks

  1. Support Staff 1 Posted by Feodor Fitsner on 01 Jul, 2015 02:42 PM

    Feodor Fitsner's Avatar

    Looking into that.

    - Feodor

  2. 2 Posted by stage.innovadis on 01 Jul, 2015 02:52 PM

    stage.innovadis's Avatar

    I actually found out I was using an account which didnt have full acces/rights. A co-worker logged in with his VSO account and it worked.

  3. Support Staff 3 Posted by Feodor Fitsner on 01 Jul, 2015 02:53 PM

    Feodor Fitsner's Avatar

    Ah, OK. So the problem has gone?

    - Feodor

  4. 4 Posted by stage.innovadis on 01 Jul, 2015 03:00 PM

    stage.innovadis's Avatar

    Well I have got my project loaded now as intended and everything works fine. But like I said, with my co-workers account. I assume it has something to do with my rights on VSO.

    Im almost done testing a build here. After, I will try to reproduce the problem. And see what the differences are with rights on VSO. Maybe that could shed some light on the problem.

  5. Support Staff 5 Posted by Feodor Fitsner on 01 Jul, 2015 03:05 PM

    Feodor Fitsner's Avatar

    Sure, please let me know about your findings.

    - Feodor

  6. 6 Posted by stage.innovadis on 01 Jul, 2015 03:15 PM

    stage.innovadis's Avatar

    This is the error I got trying with my own VSO account.
    http://i.imgur.com/USOut1q.png

    It seems to be indeed 'forbidden' for my VSO account. Weird that it gives js errors though. Seeing internal server error made me think it was not a VSO problem.

  7. Support Staff 7 Posted by Feodor Fitsner on 01 Jul, 2015 03:18 PM

    Feodor Fitsner's Avatar

    What was the missing permission on VSO side?

  8. 8 Posted by stage.innovadis on 02 Jul, 2015 08:18 AM

    stage.innovadis's Avatar

    Guess I found it:

    From: https://www.visualstudio.com/en-us/get-started/integrate/integrating-with-service-hooks-vs
    'By default, only project administrators have these permissions.'

    After looking into the project settings, it indeed seems to be the problem:
    http://imgur.com/L5UJVqW

  9. Support Staff 9 Posted by Feodor Fitsner on 02 Jul, 2015 09:03 PM

    Feodor Fitsner's Avatar

    Right, thanks for letting me know!

  10. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac