Timeout pushing artifacts

iburgueno's Avatar

iburgueno

01 Jul, 2015 09:38 PM

Hi. By the huge speedups I'm experiencing on the job's execution times (huge thanks for that!), it seems that I'm running on the new environment.
However, my jobs can't push artifacts no more. They fail with the following error:

Error pushing artifact: The operation has timed out

An example job is here.

Thanks in advance

  1. Support Staff 1 Posted by Feodor Fitsner on 01 Jul, 2015 09:46 PM

    Feodor Fitsner's Avatar

    How large is that artifact?

  2. 2 Posted by iburgueno on 01 Jul, 2015 09:53 PM

    iburgueno's Avatar

    Around 90Kb.

    07/01/2015  09:49 PM            91,049 luawinmake-964ee2420cdf2f9ed79f62bdd7ce2445379b0c02-x86-2015.7z  
                   1 File(s)         91,049 bytes
    
  3. Support Staff 3 Posted by Feodor Fitsner on 01 Jul, 2015 10:00 PM

    Feodor Fitsner's Avatar

    When was the last time it worked?

  4. 4 Posted by iburgueno on 01 Jul, 2015 10:01 PM

    iburgueno's Avatar

    I haven't tried to push artifacts in this particular project before.

  5. 5 Posted by iburgueno on 01 Jul, 2015 10:19 PM

    iburgueno's Avatar

    Just checked with a different project which was pushing artifacts already. Seems it is running on the new infrastructure and it succesfully uploaded the artifacts.
    Here is the link, if it is any help for you:

    https://ci.appveyor.com/project/ignacio/luanode/build/job/tmqrt6d5k...

  6. Support Staff 6 Posted by Feodor Fitsner on 01 Jul, 2015 10:28 PM

    Feodor Fitsner's Avatar

    Interesting. Indeed, both projects are running on a new environment.

  7. Support Staff 7 Posted by Feodor Fitsner on 01 Jul, 2015 10:37 PM

    Feodor Fitsner's Avatar

    Btw, try uploading artifact from PowerShell, kind of:

    on_success:
    ...
    - ps: Push-AppveyorArtifact "luawinmake-$env:APPVEYOR_REPO_COMMIT-$env:platform-$env:Configuration.7z"
    
  8. 8 Posted by iburgueno on 01 Jul, 2015 10:59 PM

    iburgueno's Avatar

    It is funny... It works that way. Log available here.

    Tried to use the appveyor.exe from the .yml file directly but that also fails with timeout.

    I don't mind changing the script to use powershell, but, do you want me to try anything else, so to isolate the problem with the .exe ?

  9. Support Staff 9 Posted by Feodor Fitsner on 01 Jul, 2015 11:09 PM

    Feodor Fitsner's Avatar

    Good question. Both appveyor.exe and PowerShell use the same assembly to call worker API. The only difference is that PowerShell is called inside build agent process while appveyor.exe is a new process. Maybe something related to env variables or connections limit.

    Let me try changing connections limit and send you an updated appveyor.exe...

  10. Support Staff 10 Posted by Feodor Fitsner on 01 Jul, 2015 11:16 PM

    Feodor Fitsner's Avatar

    OK, try adding that into install section of appveyor.yml:

    - ps: "'<?xml version=\"1.0\" encoding=\"utf-8\" ?> \n<configuration> \n <system.net> \n  <connectionManagement> \n   <add address=\"*\" maxconnection=\"100\" /> \n  </connectionManagement> \n </system.net> \n</configuration>' | Out-File 'C:\\Program Files\\AppVeyor\\BuildAgent\\appveyor.exe.config'\n"
    

    It increases the maximum connections for appveyor.exe.

    Let me know if that worked.

  11. Support Staff 11 Posted by Feodor Fitsner on 02 Jul, 2015 05:13 AM

    Feodor Fitsner's Avatar

    Nope, it didn't work - I tested on my fork. Will try something else tomorrow.

  12. 12 Posted by iburgueno on 02 Jul, 2015 01:51 PM

    iburgueno's Avatar

    Thanks for your help. Ping me if you need any assistance.

  13. 13 Posted by iburgueno on 13 Jul, 2015 03:59 PM

    iburgueno's Avatar

    Hi. Do you have any news regarding this issue?

  14. Support Staff 14 Posted by Feodor Fitsner on 13 Jul, 2015 04:02 PM

    Feodor Fitsner's Avatar

    Nope. Still can't understand why in some cases it doesn't work from appveyor.exe.

    - Feodor

  15. 15 Posted by iburgueno on 18 Aug, 2015 09:51 PM

    iburgueno's Avatar

    Hi Feodor.
    I've just tried this again, and now it is working fine when pushing artifacts directly from the appveyor.yml file, but not when being called from a batch file.

  16. Support Staff 16 Posted by Feodor Fitsner on 18 Aug, 2015 09:55 PM

    Feodor Fitsner's Avatar

    Could you please do a very simple repro in a public repository?

    - Feodor

  17. 17 Posted by iburgueno on 18 Aug, 2015 10:07 PM

    iburgueno's Avatar

    This repo is public:
    https://github.com/ignacio/luawinmake/tree/appv

    That branch has the code that is failing. Minutes ago, all jobs were getting stuck. Now some of them work, some of they time out.

    Is that what you asked for?

  18. 18 Posted by Thijs Schreijer on 19 Aug, 2015 07:52 PM

    Thijs Schreijer's Avatar

    Here's another one that just failed (same Github project); https://ci.appveyor.com/project/Tieske/luawinmake/build/0.0.1.7-test

  19. 19 Posted by Thijs Schreijer on 19 Aug, 2015 08:15 PM

    Thijs Schreijer's Avatar

    And the exact same commit ran ok here; https://ci.appveyor.com/project/Tieske/luawinmake/build/0.0.1.8-test

    The failed one was a new branch, while this one is the PR of that same branch (so content is identical)

  20. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:59 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac