Problem in building Xamarin Android project

rajindersingh's Avatar

rajindersingh

04 Jul, 2015 10:43 PM

Hi:

Our source code is in VS Online. We were told that we have been added to OSS to be able to build Xamarin android projects.
I created 2 environment variables xamarin_email and xamarin_password. Both of there were secure variables. I encrypted the using the Account encrypt data. I copied and pasted them directly in to the GUI.
In Xamarin have Xamarin android license which has not been assigned to a computer.
I added the command to register for android builds.

I am getting this error:

Error activating Xamarin license: Unable to get Xamarin account: Invalid username or password.
Command exited with code 2

I use the same user name and login to log into the Xamarin portal. However in AppVeyor I am encrypting user name and password.

I have never used secure variable before. I just added a variable and pasted the encrypted values in it.

Let me know if you have any suggestion for how to debug this issue.

  1. Support Staff 1 Posted by Feodor Fitsner on 04 Jul, 2015 10:51 PM

    Feodor Fitsner's Avatar

    When setting up variables on Environment tab of project settings you don't have to encrypt them using Encrypt data page. That encryption tool is for appveyor.yml only.

  2. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac